Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Platinum maXbimmer Sponsors > RMP Motors
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-08-2011, 10:59 PM   #1
BlueBimmer09
2nd Gear Member
 
Join Date: May 2009
Location: Toronto
Posts: 51
Creaking sound from Rear passenger side

Hi,

Recently I have been hearing a slight creaking sound from the rear driver passenger side of my bmw 330ci. The sound is coming from the bottom of the car.

This sound happend when I engage the clutch at low speeds. The sound is the strongest in first gear when I start at low speeds.

Do you have any idea what the problem might be and how much It might cost to fix.
BlueBimmer09 is offline   Reply With Quote
Old 10-09-2011, 08:56 PM   #2
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
Take a look at your rear shock tower mounts. One, if not both are probably torn. This sounds like the beginning stages of the issue. Eventually both will tear, and you'll hear the sound all the time.

Go to the truck and lift up the carpet around the wheel wells. If there is an issue with your mounts, it will be obvious.

The other problem this could be is the rear control arms. Have a look at this too, but I'm gonna say it's your mounts almost for sure.
__________________


flickr
craigIS is offline   Reply With Quote
Old 10-16-2011, 06:03 PM   #3
ToccaTocca
Banned
 
Join Date: Oct 2011
Location: GTA
Posts: 8
Quote:
Originally Posted by craigIS View Post
Take a look at your rear shock tower mounts. One, if not both are probably torn. This sounds like the beginning stages of the issue. Eventually both will tear, and you'll hear the sound all the time.

Go to the truck and lift up the carpet around the wheel wells. If there is an issue with your mounts, it will be obvious.

The other problem this could be is the rear control arms. Have a look at this too, but I'm gonna say it's your mounts almost for sure.
Before we guess like Canadian tire techs, did you get this checked out by a professional?
ToccaTocca is offline   Reply With Quote
Old 10-17-2011, 08:33 PM   #4
BlueBimmer09
2nd Gear Member
 
Join Date: May 2009
Location: Toronto
Posts: 51
No, I did not get a checked yet. Been too busy with work to do anything, I might drop by RMP to get it checked when I get a chance.
BlueBimmer09 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:53 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.