Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-02-2011, 10:44 AM   #1
dcramer
5th Gear Member
 
Join Date: Nov 2010
Location: Orangeville
Posts: 1,084
radio and climate control both just went

Was driving and my radio all of a sudden decided to change the station, now none of the buttons work. Also the climate control computer now doesn't light up, and the buttons don't function.


There must be a common connection here... anyone ?

Dave
dcramer is offline   Reply With Quote
Old 08-02-2011, 12:23 PM   #2
ScotcH
6th Gear Member
 
Join Date: Dec 2003
Location: Ottawa, ON
Posts: 1,861
fuse?
__________________
2007 BMW 328Xi Touring, 6 speed
ScotcH is offline   Reply With Quote
Old 08-02-2011, 12:25 PM   #3
dcramer
5th Gear Member
 
Join Date: Nov 2010
Location: Orangeville
Posts: 1,084
radio works, but none of the buttons work. climate control has no display, no buttons work, but A/C is on ?

There seems to be some capacitor problem reported on the net in the climate control, but it seems odd to take them both out at the same time.
dcramer is offline   Reply With Quote
Old 08-02-2011, 01:51 PM   #4
ScotcH
6th Gear Member
 
Join Date: Dec 2003
Location: Ottawa, ON
Posts: 1,861
I'd still check fuses ... sometimes there are fuses just for the displays in the units. I suppose a short could take out the radio at the same time, or just a bad coincidence.
__________________
2007 BMW 328Xi Touring, 6 speed
ScotcH is offline   Reply With Quote
Old 08-02-2011, 04:23 PM   #5
dcramer
5th Gear Member
 
Join Date: Nov 2010
Location: Orangeville
Posts: 1,084
started it again and the radio came back, started it once more and the climate control came back. I'm sure that's not the last of it, but at the moment it will be hard to find.
dcramer is offline   Reply With Quote
Old 08-04-2011, 09:58 PM   #6
dcramer
5th Gear Member
 
Join Date: Nov 2010
Location: Orangeville
Posts: 1,084
http://macadamizer.com/bmwfix.html

is the fix
dcramer is offline   Reply With Quote
Old 08-05-2011, 01:33 PM   #7
Dysantic
Captain Chaos
 
Dysantic's Avatar
 
Join Date: May 2008
Location: Mississauga
Posts: 1,029
Quote:
Originally Posted by dcramer View Post
My CC dropped out on me a few months back and I did this fix. Works like a charm now. Not sure about the OBC, but like stated earlier, the fuse might be starting to go or could just be loose. That would be where I first look. No point in tearing the CC apart if its just the fuse. lol
__________________
Dysantic is offline   Reply With Quote
Old 08-05-2011, 02:10 PM   #8
dcramer
5th Gear Member
 
Join Date: Nov 2010
Location: Orangeville
Posts: 1,084
my guess is this capacitor shorts out and causes voltage drop which affects the radio. Either way mine's all good now
dcramer is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.