Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 07-20-2011, 01:12 PM   #1
mazdaRXwhat
2nd Gear Member
 
Join Date: Feb 2009
Location: Brampton
Posts: 173
E39 lcm

Anybodys had to replace theirs?
My turn signals have stopped working all together now, the bulds arent burnt cuz they still flash when locking/unlocking car and when using the 4 ways. Also dont have use of high beams either

Everything ive read points to the LCM going tits up.

Any advise?
mazdaRXwhat is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014