Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-20-2011, 12:12 PM   #1
mazdaRXwhat
2nd Gear Member
 
Join Date: Feb 2009
Location: Brampton
Posts: 173
E39 lcm

Anybodys had to replace theirs?
My turn signals have stopped working all together now, the bulds arent burnt cuz they still flash when locking/unlocking car and when using the 4 ways. Also dont have use of high beams either

Everything ive read points to the LCM going tits up.

Any advise?
mazdaRXwhat is offline   Reply With Quote
Old 07-20-2011, 12:59 PM   #2
radi0activem
3rd Gear Member
 
Join Date: Jan 2010
Location: Ottawa, ON, Canada
Posts: 309
Might as well have some fun with it if you're going to replace it....

http://www.europeanautosource.com/pr...oducts_id=1868
__________________
Brian
------------
2003 530i
radi0activem is offline   Reply With Quote
Old 08-16-2011, 06:24 PM   #3
tiger
2nd Gear Member
 
Join Date: Mar 2005
Location: pickering
Posts: 96
I have a 98--540 and have the same problem Charlie at Bimmersport is sure that the LCM is gone for the left side. The only problen is sometimes you have to buy a new part for this and the cost is about $800 plus install. You can try a use one which is much cheaper but might not work
tiger is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.