Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-07-2011, 01:34 PM   #1
aceSpec
1st Gear Newbie
 
Join Date: Feb 2009
Location: Hamilton
Posts: 35
brakelight & indicator not working; bad connection

Hey all,

I have an 05 325i, and recently my rear driver side indicator and then my brake light stopped working. After some investigation I found my connector looking like this:
WP_000149.jpgWP_000152.jpg
WP_000153.jpgWP_000154.jpg

Is this a whole harness replace? Peice of a harnes?

Looks like something may have shorted...any tips on figuring out the issue?

Any suggestions on where to go from where would be helpful (other than "fix it"...lol)

Thanks for the help.
aceSpec is offline   Reply With Quote
Old 04-09-2011, 12:04 PM   #2
uzi577
RUNING BOOST
 
uzi577's Avatar
 
Join Date: May 2009
Location: Toronto
Posts: 258
hey, that look pretty bad
I would contact Eurostyle get a new/used harness.
Before you do it however see if you don't have some obvious shorts.
uzi577 is offline   Reply With Quote
Old 04-10-2011, 10:07 PM   #3
Junaid
4th Gear Member
 
Join Date: Nov 2007
Location: Toronto
Posts: 670
Where the trunk closes there is a black harness which connects the wires to the trunk, cut that open and see if any wires are broken and proceed from there.
__________________


Needs more mods
Junaid is offline   Reply With Quote
Old 04-12-2011, 07:06 PM   #4
MANDD
Autobahn East
 
Join Date: Jul 2005
Location: Ajax
Posts: 261
Common failure on E46. That wire is the tail light ground. Cut the wire and discard the burned terminal.

Crimp new wire about 2'' to the wire you just cut. Get a spade terminal and crimp it to the new wire.

If you look closely at the tail light board you will see a spot near the bottom where the spade terminal can connect to.

Plug the connector back in and you should be good to go.

Mark.
MANDD is offline   Reply With Quote
Old 04-13-2011, 11:07 AM   #5
aceSpec
1st Gear Newbie
 
Join Date: Feb 2009
Location: Hamilton
Posts: 35
Cool. Thanks for the advice, i'll let you now what happens.

Just for kicks though, I went to BMW just to hear what they say and get numbers from them (always fun at the stealership). Here is a price quote they have me on fixing both taillights:

WP_000166.jpg
aceSpec is offline   Reply With Quote
Old 04-27-2011, 10:01 AM   #6
aceSpec
1st Gear Newbie
 
Join Date: Feb 2009
Location: Hamilton
Posts: 35
Thanks for the help guys, got it all fixed!
aceSpec is offline   Reply With Quote
Reply

Tags
harnes, light, short, wiring

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:42 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.