Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E90/E91/E92/E93
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-21-2011, 10:12 AM   #1
noeddeon
1st Gear Newbie
 
Join Date: Jan 2011
Location: Toronto
Posts: 1
Complete power failure / Electronics Issue

I've been having some (electronics) problems with my 2007 328i Cabriolet.
Occasionally the ABS light with (!) comes on in the cluster along with a few other lights and I will lose all sound from the radio, no Aux, no Bluetooth etc.

I took it to the dealer in December to fix and they recode the system.

Yesterday I was driving and the cluster lit up like a Christmas tree again with all the lights mentioned above. I stopped, shut the car off and when I tried turning the car back on, I could not ... TOTAL LOSS OF POWER. Key would not come out of ignition, no lights for hazards etc. I had to get it towed to the dealer, but while the car is on the tow going to dealer (maybe about half hour later and about 500 metres) the headlights came on (remember key was still in ignition). So we stopped and checked what was going it. Tried starting it and it started fine, however, all the electronics (radio, time etc) were 'zeroed' ( _ _ :_ _). It's as if the battery was disconnected or something.

Has anyone experienced this sorta thing or know what could be the issue? Is it just something simple as the battery leads were loose or something? Or am looking at something major?

The good news is it's still under warranty until July.

Thanks in advance.
noeddeon is offline   Reply With Quote
Old 01-21-2011, 11:07 AM   #2
sparkybp
Tortures BMWs.
 
sparkybp's Avatar
 
Join Date: May 2009
Location: Kitchener, Ontario
Posts: 347
In the trunk, on the positive cable going to your battery there is sort of a "safety disconnect" which is normally meant to pop out in case of an accident so that you don't have electricity hovering around gas spills and what not. sometimes it get knocked loose so you can check by pulling back and forth on the positive battery cable lightly.
__________________
Good discounts on all OEM and good quality aftermarket BMW parts. 519-498-9660.
sparkybp is offline   Reply With Quote
Old 01-21-2011, 11:40 AM   #3
Blades
Your opinion is to long
 
Blades's Avatar
 
Join Date: Feb 2005
Location: Mississauga
Posts: 5,344
last time i had something like that the alternator went in my car or was slipping (bad belt)
__________________
-=[ BL/\DES ]=-



All it takes is one bad day to reduce the sanest man alive to lunacy. Thats how far the world is from where i am. just one bad day. - Unknown
Blades is offline   Reply With Quote
Old 01-21-2011, 02:29 PM   #4
MANDD
Autobahn East
 
Join Date: Jul 2005
Location: Ajax
Posts: 263
Possibly failure of the ELV with no terminal 15 activation, quite common on the E90 I see quite a few of these issues.

The IBS may cause the same issue.

Mark.
MANDD is offline   Reply With Quote
Old 03-02-2011, 06:55 PM   #5
BimmerboyPH
5th Gear Member
 
BimmerboyPH's Avatar
 
Join Date: Jun 2006
Location: Smithville
Posts: 981
Check the main power supply going to the fuse box behind the glove box. Check its connection and make sure its not burnt or shorting.
__________________
88 325is- written off
89 735i 5 spd- traded
89 325is m50 swap- sold
92 325is- sold
97 328is- sold
00 Land Rover Disco- sold
07 328i- sold
84 325e- track car, in progress........ SOLD!
87 325is- FOR SALE
98 328is- Current Daily
BimmerboyPH is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.