Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-03-2011, 03:24 PM   #1
AlpWhitE46
is a pimp
 
AlpWhitE46's Avatar
 
Join Date: Apr 2002
Location: Etobicoke
Posts: 9,065
Send a message via MSN to AlpWhitE46
Oil light randomness?

I got my oil done maybe 3-4 weeks ago...

Note though, about 6-8 months ago i got my vanos fully done from dr vanos, but to this day i still dont know the guy doing it put everything correctly, as from time to time the car will start a bit odd..


anyways since that oil change... every now and then when i start the car, the oil lamp will turn on (yellow) and stay on for 15 seconds and off it will go...


wtf?
AlpWhitE46 is offline   Reply With Quote
Old 02-03-2011, 03:35 PM   #2
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,361
Don't worry bout it; do you have sufficient oil pressure? car performs normally? then I wouldn't give it much concern until your vanos craps out and then take it back to the doc.
maybe it's just the oil pressure switch. could be when he redid the vanos may have touched something by mistake..Keep in mind it is pretty cold out so the pressure takes a bit of time to build up.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is online now   Reply With Quote
Old 02-03-2011, 03:48 PM   #3
dbworld4k
Addict
 
dbworld4k's Avatar
 
Join Date: Aug 2006
Location: YYZ / ORD
Posts: 7,215
Faulty oil level sensor. Very common E46 problem. Mine has been doing this since I've owned it but I'm too lazy to change out the sensor. That, and it's ~$200 for that stupid part.
__________________


'02 ///M5 Imola Red / Imola Red '09 335i Alpine White / Coral Red

Past:
'04 E55 AMG Brilliant Silver / Anthracite
'96 318i Alpine White / Black
'01 330Ci Titanium Silver / Coral Red
'96 328i Jet Black / Black
dbworld4k is offline   Reply With Quote
Old 02-03-2011, 03:51 PM   #4
Michel
6th Gear Member
 
Michel's Avatar
 
Join Date: Jan 2007
Location: Mississauga
Posts: 1,607
if it were oil pressure, the light would be red, not yellow. Its your oil level sensor as Anuk said... make sure your oil actually isn't low though.
__________________
Michel is offline   Reply With Quote
Old 02-03-2011, 03:59 PM   #5
Seyar
4th Gear Member
 
Seyar's Avatar
 
Join Date: Oct 2006
Location: Kitchener
Posts: 643
I had the same problem and as they said its your oil level sensor, nothing to worry about.
__________________

INTERLAGOS E36
Seyar is online now   Reply With Quote
Old 02-03-2011, 04:06 PM   #6
AlpWhitE46
is a pimp
 
AlpWhitE46's Avatar
 
Join Date: Apr 2002
Location: Etobicoke
Posts: 9,065
Send a message via MSN to AlpWhitE46
ok cool thanks, oil can't be low i just got it changed

thanks guys
AlpWhitE46 is offline   Reply With Quote
Old 02-03-2011, 05:41 PM   #7
doogee
Stance is Gay.
 
doogee's Avatar
 
Join Date: Jun 2007
Location: Ancaster
Posts: 3,440
Send a message via MSN to doogee
Quote:
Originally Posted by AlpWhitE46 View Post
ok cool thanks, oil can't be low i just got it changed

thanks guys

E36's don't even have oil level sensors

Unless you're talking about your e46?
__________________


Dakar M3 Track Build Thread
doogee is offline   Reply With Quote
Old 02-03-2011, 06:01 PM   #8
AlpWhitE46
is a pimp
 
AlpWhitE46's Avatar
 
Join Date: Apr 2002
Location: Etobicoke
Posts: 9,065
Send a message via MSN to AlpWhitE46
E46, the E36 has been stored away
AlpWhitE46 is offline   Reply With Quote
Old 02-03-2011, 06:29 PM   #9
Axxe
Over 9 F**KING THOUSAND!!
 
Axxe's Avatar
 
Join Date: May 2004
Location: Oakville
Posts: 9,768
Check the oil level first. Could actually be low. Don't assume that because you just had an oil change that it's topped up.
__________________

S52|ZF|TRM Coilovers 670/895|Staggered 18" 5's
Axxe is offline   Reply With Quote
Old 02-04-2011, 06:15 PM   #10
bmdbley'sBro
wouldu like some tinfoil?
 
bmdbley'sBro's Avatar
 
Join Date: Apr 2005
Location: in your attic!
Posts: 4,647
Rear main seal ? hope not
__________________
bmdbley'sBro is offline   Reply With Quote
Old 02-05-2011, 11:01 PM   #11
new member
Banned
 
Join Date: Jan 2011
Location: GTA
Posts: 336
I love when non E46 owners try to guess the problem, lol.

Yellow oil light stays on for 10-15 sec after start up = faulty oil sensor. New one costs around $150

Yellow light at shut off = you actually are low on oil, not significant, but low. It could also be a possibility that you havent warmed up your oil before shut off and it hasnt come back down fast enough.

Yellow light while driving = you're low on oil. If it comes up when driving, means you're burning/loosing oil.

Red oil light when engine is on = low or no oil pressure. Oil pressure sensor is SEPARATE from oil level sensor just so you know.
new member is offline   Reply With Quote
Old 02-06-2011, 01:43 AM   #12
Pierce330
2nd Gear Member
 
Pierce330's Avatar
 
Join Date: Jan 2008
Location: Ontario, Canada
Posts: 220
Mine just started doing it as well...right after my last oil change...not an issue...
Pierce330 is offline   Reply With Quote
Old 02-06-2011, 08:04 AM   #13
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,361
Quote:
Originally Posted by new member View Post
I love when non E46 owners try to guess the problem, lol.

Yellow oil light stays on for 10-15 sec after start up = faulty oil sensor. New one costs around $150

Yellow light at shut off = you actually are low on oil, not significant, but low. It could also be a possibility that you havent warmed up your oil before shut off and it hasnt come back down fast enough.

Yellow light while driving = you're low on oil. If it comes up when driving, means you're burning/loosing oil.

Red oil light when engine is on = low or no oil pressure. Oil pressure sensor is SEPARATE from oil level sensor just so you know.
Hey, I'm just learning like everyone else.. thanks. :-)
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is online now   Reply With Quote
Old 02-06-2011, 01:16 PM   #14
3SERB
3rd Gear Member
 
3SERB's Avatar
 
Join Date: Aug 2004
Location: T.O.
Posts: 528
Rocco replaced my oil sensor at the last oil change. Its a two minute job and I think it was around 100 or maybe even less. Pretty useful thing to have working properly in my opinion.
__________________
...VLAD...
3SERB is offline   Reply With Quote
Old 02-06-2011, 01:18 PM   #15
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,783
dbworld4k is 100%
ever e46 will need to change this sensor sometime in it's life lol

Quote:
Originally Posted by dbworld4k View Post
Faulty oil level sensor. Very common E46 problem. Mine has been doing this since I've owned it but I'm too lazy to change out the sensor. That, and it's ~$200 for that stupid part.
BmW1819 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.