Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Misc > Off-topic
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-11-2010, 10:20 PM   #1
Jim .E.
E90 n00b
 
Jim .E.'s Avatar
 
Join Date: Jun 2003
Location: Brampton
Posts: 6,673
CPO question



My E90 burns oil and I find myself having to top it up every month because the +1L light shows up. [I drive it hard]

I use to work near 404 and Eglinton so whenever it came on I would just drive to Parkview and they would top it up no questions asked.

Fast forward 2 months and I work in Oakville and I was going to go to Budd;s but the gentleman said that they will charge me for the service as I bought the car from Endra's and not them.

I don't get it, if its a CPO - I'm pretty sure you can take it to any authorized dealer regardless where you bought the car (i.e. I bought it in Ontario, so I can take it to any dealer in Ontario).

Correct me if I'm wrong, but this pissed me off a bit today.
Jim .E. is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:37 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015