Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-19-2010, 03:20 AM   #1
Dado 540
6th Gear Member
 
Dado 540's Avatar
 
Join Date: Jan 2008
Location: GTA
Posts: 1,972
CEL on...temp gauge all the way on red...digital engine temp -128C

Driving enjoying the 540i and the "check engine" light comes on. 10 minutes after i notice the temperature gauge is all the way to the right on the "red".

I pull over immediately and check the digital engine temperature read out and it says -128C (yes negative 128)

No sign of any coolant issues. No smoke. Nada.

After fiddling around and just letting it cool off, turned the car on a few times but the needle rockets to the red zone. I figure its gotta be a malfunction with the some sensor, i started her up and drove off. Check engine light remained on, however the temperature gauge went back to slightly below the half way mark while i was driving. Engine temperature digital output was 70C and increasing slowly making its way to 85. By that time i was home and the needle was on the center.

Gonna inspect the coolant level once its cool enough, even tho i did not get "low coolant level" message. Definitely gonna have to get her scanned.

Anyone with ideas of a possible culprit(s)?
__________________
E39 540i Sport

Last edited by Dado 540; 10-19-2010 at 03:27 AM.
Dado 540 is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:58 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014