Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-05-2010, 11:30 PM   #1
Mikail
1st Gear Newbie
 
Join Date: Nov 2007
Location: Mississauga
Posts: 8
e39 2000 528i

i have a problem with my e39 528i the DSC check engine and ABS (yellow) lights on also speedmeter doesnt work...i replaced the front abs speed sensor's but it's still on what could be the problem?can someone halp!!!

Last edited by Mikail; 08-05-2010 at 11:32 PM. Reason: abs
Mikail is offline   Reply With Quote
Old 08-05-2010, 11:35 PM   #2
Mikail
1st Gear Newbie
 
Join Date: Nov 2007
Location: Mississauga
Posts: 8
e39 2000 528i ABS DSC speedmeter problem

i have a problem with my e39 528i the DSC check engine and ABS (yellow) lights on also speedmeter doesnt work...i replaced the front abs speed sensor's but it's still on what could be the problem?can someone halp!!!
Mikail is offline   Reply With Quote
Old 08-05-2010, 11:37 PM   #3
Mikail
1st Gear Newbie
 
Join Date: Nov 2007
Location: Mississauga
Posts: 8
e39 2000 528i ABS DSC speedmeter problem

i have a problem with my e39 528i the DSC check engine and ABS (yellow) lights on also speedmeter doesnt work...i replaced the front abs speed sensor's but it's still on what could be the problem?can someone halp!!
Mikail is offline   Reply With Quote
Old 08-10-2010, 01:27 AM   #4
john88
2nd Gear Member
 
Join Date: Mar 2009
Location: Richmond hill
Posts: 72
It could be a ABS module.
john88 is offline   Reply With Quote
Old 08-21-2010, 10:03 AM   #5
Arti711
1st Gear Newbie
 
Join Date: Aug 2010
Location: Orangeville
Posts: 6
it could be rear driver side ABS sensore , I had same issue and it's all gone now
if you want I could scan it for you and let you know
where about are you?
Arti711 is offline   Reply With Quote
Old 08-26-2010, 07:14 PM   #6
Mikail
1st Gear Newbie
 
Join Date: Nov 2007
Location: Mississauga
Posts: 8
i just replaced the rear driver side abs sensor today speed gauge wasnt working before it worked when the new sensor was on aboute 5 kms
after it stoped working again engine light ,abs and dsc lights was on before only the engine light whent off dsc and abs is still on....i m from brampton can you scan it saturday ??? thanks
Mikail is offline   Reply With Quote
Old 08-28-2010, 02:00 AM   #7
Arti711
1st Gear Newbie
 
Join Date: Aug 2010
Location: Orangeville
Posts: 6
if you want I can scan it on sunday around noon, I work in brampton
I work Bramalea & 407 let me know
Arti711 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:51 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014