Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-18-2010, 09:22 PM   #1
trypnotic
2nd Gear Member
 
Join Date: May 2003
Location: Mississauga
Posts: 243
Help!!!!!!! With hood latch

Im hoping someone can help me out.......I have a 2000 323ci and my hood will not open.

the cable is not snapped and i have pulled the kidney grills of and tried to release the latch but even when i pull to open it seems the hood will not release ....... I noticed that there are the 2 springs under the hood that seem to also lock..........NEED TO ADD Coolant ARE CAR IS over HEATING......Or is there someone i can go see to fix this? I'm located is Sauga.....


Cheers
trypnotic is offline   Reply With Quote
Old 04-18-2010, 09:33 PM   #2
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,363
Lube the crap out of the latch and let it sit.. then work the latch with with a screwdriver if you can to free it up before attempting the hood cable.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 04-18-2010, 11:06 PM   #3
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
Just a possibility.....there is a second cable between the 2 locks, it could be snapped. Also could be that one of the locks is effed.

Just a couple thoughts
__________________


flickr
craigIS is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:10 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.