Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Classifieds > Looking for
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-07-2009, 09:29 AM   #1
huffdaddy66
1st Gear Newbie
 
Join Date: Nov 2009
Location: Ridgetown ontario
Posts: 8
Exclamation need some help

i got a 92 325i and today i went to pop the hood to fix the headlight bulbs and whn i pulled the latch it just broke< the latch is still in place like it didnt break off but my hood wont pop now, can anyone give me some helpful tips to fix this? or should i just take it to a garage and get it fixed
huffdaddy66 is offline   Reply With Quote
 

Tags
hood, problem

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.