Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-11-2009, 09:13 PM   #1
Steve30
Techno Viking
 
Steve30's Avatar
 
Join Date: May 2008
Location: Scarborough
Posts: 1,714
just finished m50 manifold

Hey guys, I just finished my M50 manifold swap today. I Started the car up and everything was perfect except for a slightly louder top end ticking. Is this due the the engine running lean until it adapts to the new air flow? Also, i got a check engine light as soon as i got on the highway. my brother said it could be the MAF due to the new airflow. any help would be appreciated

thanks,
steve
__________________



E36 ///M3 S54
E30 325 Project
Steve30 is offline   Reply With Quote
Old 11-11-2009, 10:07 PM   #2
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,685
Send a message via MSN to propr'one
let everything adjust, see how it is tomorrow
propr'one is offline   Reply With Quote
Old 11-11-2009, 10:13 PM   #3
Steve30
Techno Viking
 
Steve30's Avatar
 
Join Date: May 2008
Location: Scarborough
Posts: 1,714
hopefully thats why the CEL came on. As for the ticking, I think its the injectors. Apparently they are loud as hell without a fuel rail cover on. I'll update this tomorrow.

Quote:
Originally Posted by propr'one View Post
let everything adjust, see how it is tomorrow
__________________



E36 ///M3 S54
E30 325 Project
Steve30 is offline   Reply With Quote
Old 11-11-2009, 10:45 PM   #4
blk325i
3rd Gear Member
 
blk325i's Avatar
 
Join Date: Feb 2006
Location: kitchener
Posts: 536
the ticking is normal, there should be no CEL, scan it, most likely a vaccum leak
blk325i is online now   Reply With Quote
Old 11-11-2009, 10:57 PM   #5
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,887
Quote:
Originally Posted by blk325i View Post
the ticking is normal, there should be no CEL, scan it, most likely a vaccum leak
+1 on the vacume leak! They can be very sensative to vacume leaks, triggering the CEL. Reset the light and see if it comes back.
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E34 E39 E60 E32 E38 E65 E66 X5 M3 M5


Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is online now   Reply With Quote
Old 11-11-2009, 11:01 PM   #6
Steve30
Techno Viking
 
Steve30's Avatar
 
Join Date: May 2008
Location: Scarborough
Posts: 1,714
i guess its time to invest in the peak engine tool
__________________



E36 ///M3 S54
E30 325 Project
Steve30 is offline   Reply With Quote
Old 11-12-2009, 12:36 AM   #7
iverson03tj
5th Gear Member
 
iverson03tj's Avatar
 
Join Date: Oct 2009
Location: Toronto, Ontario, Canada
Posts: 928
Was it an easy swap? did u use a kit or found the parts urself?
iverson03tj is offline   Reply With Quote
Old 11-12-2009, 04:29 PM   #8
Steve30
Techno Viking
 
Steve30's Avatar
 
Join Date: May 2008
Location: Scarborough
Posts: 1,714
i bought the manifold from eurostyle and i used eric's kit from m50manifold.com. the install is very straight forward. the biggest problem i had was the manifold bolt in the back. labelling all the harnesses helps a ton. it took me about 7 hours by myself.

do you think a cracked/ripped intake boot would cause the CEL? I used the original one which did have some tearing. I'm going to BMW tomorrow to buy a new one.
__________________



E36 ///M3 S54
E30 325 Project

Last edited by Steve30; 11-12-2009 at 06:34 PM.
Steve30 is offline   Reply With Quote
Old 11-13-2009, 04:21 PM   #9
iverson03tj
5th Gear Member
 
iverson03tj's Avatar
 
Join Date: Oct 2009
Location: Toronto, Ontario, Canada
Posts: 928
I dont think it Should. Do you know anyone that can tell u the code?
iverson03tj is offline   Reply With Quote
Old 11-13-2009, 04:37 PM   #10
Steve30
Techno Viking
 
Steve30's Avatar
 
Join Date: May 2008
Location: Scarborough
Posts: 1,714
My friends brother does have a code reader but I haven't had a chance to talk to him yet. I read that any leak post-MFA would throw off the CEL and cause the engine to run lean. I really dont see what else it could be. Every vacuum line is in place.
__________________



E36 ///M3 S54
E30 325 Project
Steve30 is offline   Reply With Quote
Old 11-13-2009, 08:01 PM   #11
BmW1819
6th Gear Member
 
Join Date: Feb 2007
Location: Pickering
Posts: 2,770
a cracked intake boot after the air flow meter is a vaccum leak and will through a lean mixture code
BmW1819 is offline   Reply With Quote
Old 11-13-2009, 08:52 PM   #12
Steve30
Techno Viking
 
Steve30's Avatar
 
Join Date: May 2008
Location: Scarborough
Posts: 1,714
I thought so. I ordered the boot from bmw but it wont be in until monday. Will I still need to have the CEL reset with the tool or will it correct itself?

Quote:
Originally Posted by BmW1819 View Post
a cracked intake boot after the air flow meter is a vaccum leak and will through a lean mixture code
__________________



E36 ///M3 S54
E30 325 Project
Steve30 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.