Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-30-2009, 04:26 PM   #1
juzer
7000 RPM
 
juzer's Avatar
 
Join Date: Mar 2009
Location: toronto
Posts: 192
1992 e34 535i auxiliary water pump

Auxiliary water pump, the one located under heater control valve just broke on my e34 535i, i take it out and plug the hose directly in to heater valve.

Pump was already non functional and power disconnected before.

Drove the car to home, some 20km, heating and temperature was normal, is it good idea to live it without this pump?

Also what are the symptoms if heater valve is non functional.

Radiator was replaced yesterday since the old one started leaking, can this non functional pump be reason for putting too much pressure to the rad too? im afraid of damaging the new rad.

Any help appreciated.
__________________
juzer is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:12 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.