Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-14-2009, 03:48 PM   #1
jasonlau8023
2nd Gear Member
 
Join Date: Mar 2009
Location: scarborough, ontario, canada
Posts: 62
need help for my O2 sensor

as i mentioned in my previous post that my e36 328 engine light was on, and it turns out the O2 sensor not activated or someting... but my mechanician said might not be the O2 sensor problem because the O2 sensor will only activate when the engine is fully warm..

Also, another symptom is that when the car was on highway, the engine temperature when down to 45, on local was normal around 90 or 100

so, is this because of the bad thermostat? so i need replace thermostat first and see if this O2 sensor problem will fix?

any opinion would be appreciated!!
jasonlau8023 is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:10 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.