Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Classifieds > Supporting Vendor Comments/Feedback > RMP Motors
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-21-2009, 06:58 PM   #1
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,694
Send a message via MSN to propr'one
Thumbs up Vanos work at RMP

I've had the 1519 "Vanos mechanically jamming" code on my car for about 2 years now. It took a long time for to figure out what was wrong, but ultimately Rocco fixed it, and the car runs considerably better. The vanos not working is a relatively subtle change from how the car normally runs, but it is very noticable. At low RPM's (particularly idle) there was noticably less power, and the vanos unit made a lot of noise.

The solution was purchasing the besian seals replacement kit:
http://www.beisansystems.com/products.html

(around 30$)

The installation is somewhat involved, and can take a few hours. Rocco did mine for 225$, as everything came apart quite easily. The price on a dual vanos system would likely be more. I took the opportunity to change the valve cover gasket while it was being repaired, as this did not involve any additional labour.

The car now has noticably more power, and im guessing i'll be getting at least 100 more KM a tank.

Thanks!
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 07-21-2009, 11:36 PM   #2
doogee
Stance is Gay.
 
doogee's Avatar
 
Join Date: Jun 2007
Location: Ancaster
Posts: 3,441
Send a message via MSN to doogee
Did the code go away?

Mine didn't...maybe because bimmersport did it? lol ****...
__________________


Dakar M3 Track Build Thread
doogee is offline   Reply With Quote
Old 07-22-2009, 01:00 AM   #3
tig
4th Gear Member
 
tig's Avatar
 
Join Date: Oct 2006
Location: scarborough
Posts: 736
ya what he said^^ did the code go away? cuz mine was done to and still have the code, apperantly its cuz i have s52 cams
__________________


96 318is...sold
97 328is supercharged..sold
98 740il sitting in the garage
04 645ci, 6speed, H&R coils, straight pipes, afe intake
tig is offline   Reply With Quote
Old 07-22-2009, 02:55 AM   #4
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,694
Send a message via MSN to propr'one
Its still throwing the code, but i haven't driven it enough to say anything conclusively. The hesitation at idle has been getting progressively better, it could be that the new seals are wearing themselves in. How much have you guys driven your cars since you had the seals installed?
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 07-26-2009, 11:15 PM   #5
tig
4th Gear Member
 
tig's Avatar
 
Join Date: Oct 2006
Location: scarborough
Posts: 736
I ordered the rebuilt vanos from DR Vanos which is basically the same shit anyway, the hesitation does definatly get better after a while, you are apperantly supposed to give it about 500km before everything is perfect,
i have driven over 1000km already still get the code, gonna try to get it figured out this week
__________________


96 318is...sold
97 328is supercharged..sold
98 740il sitting in the garage
04 645ci, 6speed, H&R coils, straight pipes, afe intake
tig is offline   Reply With Quote
Old 07-26-2009, 11:19 PM   #6
doogee
Stance is Gay.
 
doogee's Avatar
 
Join Date: Jun 2007
Location: Ancaster
Posts: 3,441
Send a message via MSN to doogee
Quote:
Originally Posted by propr'one View Post
Its still throwing the code, but i haven't driven it enough to say anything conclusively. The hesitation at idle has been getting progressively better, it could be that the new seals are wearing themselves in. How much have you guys driven your cars since you had the seals installed?
Probably about 4-5k
__________________


Dakar M3 Track Build Thread
doogee is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.