Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-24-2009, 08:52 AM   #1
clementine
2nd Gear Member
 
Join Date: Jan 2009
Location: mississauga, ON
Posts: 179
speedo lights dont work properly!

just wondering if anyone knows why my speedo lights dont work when they ar esupposed to? For example when the switch is on for the high beam and fogs the speedo lights dont work. thanks for your help in advance.
clementine is offline   Reply With Quote
Old 03-24-2009, 09:00 AM   #2
stan man
2nd Gear Member
 
Join Date: Jul 2008
Location: Aurora
Posts: 180
Try:

turn the lights on with the knob thing, wigle it clockwise and counterclockwise, maybe the dimmer is set too dim.

smack the dashboard above the speedometer a few times.

if none of the above works, you need to replace two bulbs inside the cluster.

Should work after
__________________
________________
stan man is offline   Reply With Quote
Old 03-24-2009, 09:10 AM   #3
craigIS
A.K.A. crossfire291
 
craigIS's Avatar
 
Join Date: Feb 2007
Location: Chatham
Posts: 2,044
Send a message via MSN to craigIS
hopefuly your dimmer is set too dim.

if you end up relpalcing the bulbs and it still doesnt work, i would check your wires and connections.
__________________


flickr
craigIS is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.