Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > Forced Induction
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Old 03-17-2009, 04:04 PM   #1
BMWCC 4928, BMWCCA 349578
Join Date: Oct 2003
Location: London, Ontario
Posts: 609
Balanced throttle at high RPM

I've got an RMS (Vortec) S/C on an OBD1 3.2L. I'm finding that the throttle response at high RPM is problematic. For instance, if I am accellerating at FT and then back-off a little at high RPM (above 5k) the engine reacts as if I suddenly lifted completely. The car reacts strongly (even a little violently). If I increase throttle a little, I get accelleration again, but when I lift (just a little) once more, I again get the whole car pitching forwards.

I'm thinking that the blow-off valve is opening completely and dumping all the boost. Shouldn't this be gradual though? I am working with MarkD to tune the car, but I'm thinking that this is not air/fuel, but rather the blow-off valve.

What do you think? If it is blow-off valve, any recommendations on replacement?
1993 325is
2002 540i M-Sport
sthomas is offline   Reply With Quote
Old 03-20-2009, 10:19 AM   #2
if I lived . I would be ~
everlast's Avatar
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
Sounds BOV related. Is the BOV adjustable? If so, it would need to be adjusted so that it only opens at the vacuum level that is present when you are completely off-throttle.

Try just unplugging the BOV and carefully test to see if the behavior is gone. (I wouldn't run it that way for very long tho unless you like blowing up pipes. )
everlast is offline   Reply With Quote
Old 09-25-2009, 09:49 AM   #3
black bnr32
3rd Gear Member
black bnr32's Avatar
Join Date: Sep 2008
Location: saskatoon
Posts: 454
Well since this was bumped anyway...

Throttle position sensor. I had a very similar scenario and that was it.
black bnr32 is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 08:04 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015