Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name

Welcome to!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Thread Tools Rate Thread Display Modes
Old 10-10-2008, 05:20 PM   #1
Helka's Avatar
Join Date: May 2006
Location: Guelph
Posts: 235
Cruise Control Faulty


This year I have noticed a problem with my cruise control in my 94 318i. I would try to set it and it seems like it engages because when I take my foot off the gas the kms per litre gauge isn't all the way at zero (which it would normally show if you let up on the gas all the way) but remains at around 4l/100km but my km/h start to drop. I then push the cruise control out to accelerate but after I let off the gas the car starts to slow down. I then realized that when I pull in on the lever to decelerate it ACCELERATES on me for about 2 seconds. It works once in a blue moon. I only use the cruise control on the 401.

Any ideas... Faulty module, problem in the wiring in the steering column or the relay (if there is one).

I tried to look in the Haines book but nothing is listed.

I have looked around online and it could be a faulty gas pedal or brake pedal sensitivity.

Any help would be greatly appreciated.

Just to reiterate, what bothers me is when I try to set it and then pull the cruise control lever towards me to decelerate and it accelerates.????


07 BMW 328i

1994 BMW 318i
1975 BMW 2002
Helka is offline   Reply With Quote

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -4. The time now is 12:06 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015