Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-28-2008, 06:52 PM   #1
Alizay
Bad Man Wagon
 
Join Date: Sep 2005
Location: Rexdale (Toronto)
Posts: 253
Xenon Headlight, left side takes a while to turn on

I have this issue with my Xenon Headlight, on the drivers side, where it won't turn on right away, it sometimes takes a while longer to turn on. Does this mean that something is going?... Do I have to replace anything? Could it be something wrong with the wiring?..

It'll turn on by itself after a little bit, sometimes a few seconds, sometimes a few minutes. It doesn't turn on because of a bump in the road or anything either, this all happens while the car is idling.

Any thoughts?
__________________


---My Ride---
2003 BMW 330i M-Package (E46)

LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 06-28-2008, 08:13 PM   #2
slemmer
Driving in the fast lane
 
slemmer's Avatar
 
Join Date: Dec 2002
Location: Missed in 'sauga
Posts: 2,989
Sounds like a ballast problem. Try swapping ballasts with the other side to see if the other side does the same. If so, the ballast is faulty.
__________________

'04 645cic
'05 GMC Sierra SLT Z71 CCSB 4x4
'02 Regal LS
'00 740i Sport
slemmer is offline   Reply With Quote
Old 07-08-2008, 02:27 PM   #3
Alizay
Bad Man Wagon
 
Join Date: Sep 2005
Location: Rexdale (Toronto)
Posts: 253
i'm gonna try that, sorry for the late response...
Also, the dealership said there were 3 parts to look out for... the bulb, the ballast, and some ignitor... they said it could be any one of those 3
__________________


---My Ride---
2003 BMW 330i M-Package (E46)

LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 07-09-2008, 12:04 AM   #4
supersane
1st Gear Newbie
 
Join Date: Jun 2008
Location: Toronto
Posts: 13
i had the same problem, try turning on the engine first.
supersane is offline   Reply With Quote
Old 07-11-2008, 10:39 AM   #5
Alizay
Bad Man Wagon
 
Join Date: Sep 2005
Location: Rexdale (Toronto)
Posts: 253
Quote:
Originally Posted by supersane View Post
i had the same problem, try turning on the engine first.
Yeah, that's not it... it happens whether the engine is on or off...
__________________


---My Ride---
2003 BMW 330i M-Package (E46)

LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 07-11-2008, 04:13 PM   #6
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,693
Send a message via MSN to propr'one
99% an ignitor issue. I'd try swapping ignitor from left to right.

You can replace the ignitor individually with an OEM peice, or replace the ballast/ignitor assembly with an aftermarket one that will be PnP into your D2S housing.
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 07-15-2008, 04:17 PM   #7
Alizay
Bad Man Wagon
 
Join Date: Sep 2005
Location: Rexdale (Toronto)
Posts: 253
Quote:
Originally Posted by propr'one View Post
99% an ignitor issue. I'd try swapping ignitor from left to right.

You can replace the ignitor individually with an OEM peice, or replace the ballast/ignitor assembly with an aftermarket one that will be PnP into your D2S housing.

Is that an easy swap?... Have any pics on how to do it?
I think the ignitor is around $300 at the dealership... any idea how much it is OEM?
__________________


---My Ride---
2003 BMW 330i M-Package (E46)

LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 09-17-2008, 10:23 AM   #8
Alizay
Bad Man Wagon
 
Join Date: Sep 2005
Location: Rexdale (Toronto)
Posts: 253
Has anyone on the board ever used any of Propr'one's bulbs/ballasts in their E46???
__________________


---My Ride---
2003 BMW 330i M-Package (E46)

LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 09-17-2008, 01:55 PM   #9
StikiGreenZ
6th Gear Member
 
StikiGreenZ's Avatar
 
Join Date: Dec 2002
Location: Milton, ON
Posts: 1,601
Send a message via MSN to StikiGreenZ
I have his bulbs in my car, work great
__________________
-

BMW 645i - Black on Red
Range Rover Sport - Black on Black
StikiGreenZ is offline   Reply With Quote
Old 09-17-2008, 02:41 PM   #10
Alizay
Bad Man Wagon
 
Join Date: Sep 2005
Location: Rexdale (Toronto)
Posts: 253
Quote:
Originally Posted by StikiGreenZ View Post
I have his bulbs in my car, work great
Do they look like stock? I'm not trying to look like a civic with blue lights, or a Benz with Purple lights here... I just want my bulbs to work, and for it to look EXACTLY like how it did previously.
__________________


---My Ride---
2003 BMW 330i M-Package (E46)

LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.