Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-21-2008, 08:50 PM   #1
slimjim
Almost Sideways
 
Join Date: Nov 2007
Location: canada
Posts: 1,876
defroster not working

ok, this is getting annoying now, my windows are always fogged up and i cant see shit when backing up etc... my defroster does not work, is this common problem in e30's? because my buddies doesnt work aswell... any suggestions?

thanks, jake.
slimjim is offline   Reply With Quote
Old 02-21-2008, 09:07 PM   #2
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,304
check fuses, check the switch, then check for power at the rear glass.

If you determine you have power, then you'll most likely have to replace the rear glass.
__________________
T.Dot_E30 is online now   Reply With Quote
Old 02-21-2008, 09:14 PM   #3
e30_kid89
The Afro-stig
 
e30_kid89's Avatar
 
Join Date: Nov 2005
Location: TDot West End
Posts: 4,591
Send a message via MSN to e30_kid89
I have a rear glass, $40. defrosters worked mint.
__________________
e30_kid89 is online now   Reply With Quote
Old 02-22-2008, 09:29 AM   #4
supernaught
6th Gear Member
 
supernaught's Avatar
 
Join Date: Aug 2006
Location: Peterborough
Posts: 1,324
Send a message via MSN to supernaught
all windows or just rear? blower/heat not working?
__________________

88 325IX TOURING DiamantSchwarz|89 325IX AlpinWeiss|88 325IX DiamantSchwarz
supernaught is offline   Reply With Quote
Old 02-22-2008, 02:40 PM   #5
slimjim
Almost Sideways
 
Join Date: Nov 2007
Location: canada
Posts: 1,876
Quote:
Originally Posted by supernaught View Post
all windows or just rear? blower/heat not working?
just my rear.
slimjim is offline   Reply With Quote
Old 02-25-2008, 03:28 PM   #6
bimmer1989
2nd Gear Member
 
bimmer1989's Avatar
 
Join Date: Feb 2008
Location: ontario
Posts: 71
check

I had almost the same problem there was water in my trunk and when i turned my heater on the car would heat up and all the humidity caused by the water would condence on my windows so if your windows are fogging up bad enough that you cannot see out of it there is probably water some were in the car.
bimmer1989 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:07 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.