Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E36 (1991 - 1999)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 02-05-2008, 06:48 PM   #1
m3guy
1st Gear Newbie
 
Join Date: Jan 2008
Location: toronto
Posts: 9
PLEASE HELP!!! In NEED OF HELP

Ok so here is the situation hopefully u guys can shed some light,
the car is 92 318i with m42 engine

I went for my first e test last sat- failed bad Co% was 7.32 max is .036 I replaced the O2 sensor and brought me down to 1.37 still very high meaning running rich still right? What I have done is replaced plugs fuel filter and o2 sensor,I even tryed the menthol hydrate trick it brought my reading down abit on my hc suppose yto read I think 64 was 84 still not enough,Left the test place and threw another code for MAF...Im like wtf,Went to the scrap yard today picked one up from a 93 318is 1.8 code is still present but runs even worse smells very rich idle bounces all over the board at a light and almost stalls,Could this be a bad MAF too? Im stumped any help is greatly appreciated thank in advance.
m3guy is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.