Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-05-2007, 07:32 PM   #1
cdb
2nd Gear Member
 
cdb's Avatar
 
Join Date: Dec 2005
Location: Toronto
Posts: 255
Looking for Shop to Install HIDs

I just bought an HID kit for my 5 series and was looking for a reputable shop in the GTA to install them. Any reccomedations? Also, approximate pricing for installation?
Thx.
cdb is offline   Reply With Quote
Old 12-06-2007, 04:52 PM   #2
kurupt_k
www.gotHID.ca
 
kurupt_k's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 311
Ill do it for $40, what year is it?
kurupt_k is offline   Reply With Quote
Old 12-06-2007, 04:54 PM   #3
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
you could do it yourself, it's not that hard. It's basically the same as changing a light bulb, cept you have to find a place to mount a ballast. If you bought from propr'one, then he usually helps with the install if he has time.
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 12-06-2007, 08:33 PM   #4
cdb
2nd Gear Member
 
cdb's Avatar
 
Join Date: Dec 2005
Location: Toronto
Posts: 255
its a 98 528i...
cdb is offline   Reply With Quote
Old 12-09-2007, 12:08 PM   #5
kurupt_k
www.gotHID.ca
 
kurupt_k's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 311
done and done turned out amazing
kurupt_k is offline   Reply With Quote
Old 12-09-2007, 01:14 PM   #6
maxevo
4th Gear Member
 
maxevo's Avatar
 
Join Date: Dec 2005
Location: Richmondhill
Posts: 871
bimmersport , Ask for charlie
__________________
maxevo is offline   Reply With Quote
Old 12-09-2007, 07:37 PM   #7
Deep 3.2TL
6th Gear Member
 
Deep 3.2TL's Avatar
 
Join Date: May 2004
Location: Milton
Posts: 3,228
^^^^

I think you are a little late...
__________________

2007 Z4 3.0si
Deep 3.2TL is offline   Reply With Quote
Old 12-09-2007, 11:04 PM   #8
slemmer
Driving in the fast lane
 
slemmer's Avatar
 
Join Date: Dec 2002
Location: Missed in 'sauga
Posts: 2,991
Did you get any lamp out error messages after the install?
slemmer is offline   Reply With Quote
Old 12-11-2007, 09:03 AM   #9
cdb
2nd Gear Member
 
cdb's Avatar
 
Join Date: Dec 2005
Location: Toronto
Posts: 255
no actually no low beam error messages whatsoever so far. surprised me and kurupt_k(did the install) both.
cdb is offline   Reply With Quote
Old 12-11-2007, 11:34 AM   #10
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,702
Send a message via MSN to propr'one
Chris, did you run a relay on this install?
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is online now   Reply With Quote
Old 12-11-2007, 02:33 PM   #11
kurupt_k
www.gotHID.ca
 
kurupt_k's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 311
no i didnt, his kit didnt come with one. but even on my own car im not running one, and i dont get the error message either, its wierd because i use to but now i dont.
kurupt_k is offline   Reply With Quote
Old 12-11-2007, 05:32 PM   #12
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,702
Send a message via MSN to propr'one
With the relay you are 100% sure of getting LBF failure.
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is online now   Reply With Quote
Old 12-11-2007, 06:25 PM   #13
Deep 3.2TL
6th Gear Member
 
Deep 3.2TL's Avatar
 
Join Date: May 2004
Location: Milton
Posts: 3,228
so you will get the light out failure light using a relay? I thought the relay was supposed to help stop that..
__________________

2007 Z4 3.0si
Deep 3.2TL is offline   Reply With Quote
Old 12-11-2007, 07:03 PM   #14
Gamite
Moderator
 
Gamite's Avatar
 
Join Date: Dec 2001
Location: Toronto
Posts: 21,083
his relay is a wiring bypass. The kit is powered from the battery instead of the headlight wires
__________________
www.gamite.net

Gamite is offline   Reply With Quote
Old 12-12-2007, 12:33 AM   #15
kurupt_k
www.gotHID.ca
 
kurupt_k's Avatar
 
Join Date: Apr 2006
Location: Mississauga
Posts: 311
hence why i didnt use one lol
kurupt_k is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.