Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-22-2007, 12:12 PM   #1
kemestry
2nd Gear Member
 
Join Date: Apr 2007
Location: Toronto
Posts: 93
Angry Okay, I'm wtf??!??

I had 2 days off work so I thought, let me take care of that gas gague peoplem that has been an issue with my '89 325i for the past month.

1.So I go and grab a fuel sender from Standard [btw there is an '85 e30 there as soon as you walk into the lot - stripped but still some shit there] Cost me $15.00 and a nice outing with pops so I was happy. Replaced mine which was shit because when I turned the old one upside down, brown gunge came out of the hole and I didn't hear the float slide. I turn her over, nothing. Gas guage is stuck at full. SHIT.

2. So I'm like, must be my SI board batteries. I know one is dead so I'll just get those replaced. Found a place in Mississauga that sells them for $8.95 each [BBM battery - 3v 1/2 aa Lithium] so I'll eat the cost and make the trip to the west end. Install them and nothing. Sure my km/L thing works now and I'm happy about that, but shit its not what I wanted. SHIT

So here I am, back at work still counting KM's. What am I missing? Do I need a new cluster? Let me know.

Thanks
kemestry is offline   Reply With Quote
Old 08-22-2007, 06:56 PM   #2
dgmorr
4th Gear Member
 
Join Date: May 2006
Location: Mississauga
Posts: 835
Did you buy a new sender?
dgmorr is offline   Reply With Quote
Old 08-23-2007, 09:32 AM   #3
kemestry
2nd Gear Member
 
Join Date: Apr 2007
Location: Toronto
Posts: 93
the sender I got was from Standard Auto Wreckers
kemestry is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:48 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.