Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > Classifieds > Supporting Vendor Comments/Feedback > RMP Motors
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 05-17-2007, 03:07 PM   #1
myndgone
..... kLaSSe~1 .....
 
myndgone's Avatar
 
Join Date: Feb 2005
Location: Brampton
Posts: 2,942
Send a message via MSN to myndgone
Thumbs up RMP strikes again!!!

Got a few things done today, scanned & cleaned my ABS/traction sensor that was giving me trouble, my idle would go up 2-300RPM occasionally, checked for vacuum leaks, and bothered Rocco to check for few noises and rattles, which he took care of, as usual.

Never got a chance to post a pic of Rocco's job on installing my muffler and rear M-bumper, so here it is...


Order those parts for me Rocky, I'll swing by tomorrow again!!!

for Rocco & Mark!!!

and oh...thanks for Stella!!!
Attached Images
File Type: jpg rr1.jpg (113.8 KB, 80 views)
File Type: jpg rr2.jpg (110.2 KB, 80 views)
myndgone is offline   Reply With Quote
 

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:46 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.