Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-24-2014, 09:58 PM   #1
bimmere30
2nd Gear Member
 
Join Date: Aug 2012
Location: GTA
Posts: 130
e30 running rich

what should i do? adjust the afm? btw i have a rough idle ... and so far i installed new spark plugs air filter and fuel filter already, and wires are only 30,000kms broken into.
bimmere30 is offline   Reply With Quote
Old 06-25-2014, 06:47 AM   #2
325isdan
5th Gear Member
 
Join Date: Jun 2007
Location: GTA
Posts: 1,104
How rich are you running?
325isdan is online now   Reply With Quote
Old 06-25-2014, 08:21 AM   #3
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,363
Do not mess with those settings...they are set by factory unless someone else had already tampered with it. You mess with that and you may not be able to get it back to normal.

are you absolutely sure you have the plug wires on correctly. check again at the motor and dist block.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 06-25-2014, 04:24 PM   #4
bimmere30
2nd Gear Member
 
Join Date: Aug 2012
Location: GTA
Posts: 130
Quote:
Originally Posted by Ceeker View Post
Do not mess with those settings...they are set by factory unless someone else had already tampered with it. You mess with that and you may not be able to get it back to normal.

are you absolutely sure you have the plug wires on correctly. check again at the motor and dist block.
i dropped my afm several times on grass maybe its retarded now
bimmere30 is offline   Reply With Quote
Old 06-25-2014, 09:48 AM   #5
cirrusblau
3rd Gear Member
 
Join Date: Mar 2008
Location: GTA
Posts: 356
Is the FPR working properly? What about the O2 sensor?
__________________
Parts for Sale (Updated 2014-04-10) http://ethirty.velcomweb.ca/
cirrusblau is offline   Reply With Quote
Old 06-25-2014, 04:21 PM   #6
bimmere30
2nd Gear Member
 
Join Date: Aug 2012
Location: GTA
Posts: 130
i installed a new frp, i havent installed the o2
bimmere30 is offline   Reply With Quote
Old 06-25-2014, 04:59 PM   #7
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,363
maybe on concrete but grass shouldn't make a diff.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 06-25-2014, 05:16 PM   #8
cirrusblau
3rd Gear Member
 
Join Date: Mar 2008
Location: GTA
Posts: 356
Are all your connections good? If the car gets stuck in open loop control, it will default to be very rich, but I think it would also throw a code if something like the AFM wasn't fully connected.

Are your temp sensors working properly?
__________________
Parts for Sale (Updated 2014-04-10) http://ethirty.velcomweb.ca/
cirrusblau is offline   Reply With Quote
Old 06-25-2014, 06:09 PM   #9
bimmere30
2nd Gear Member
 
Join Date: Aug 2012
Location: GTA
Posts: 130
Coolant temp sensor looks old, yeah the connections are good I did the stomp test and got a 1215 code, so I checked the connections and they are good, but still I'm running rich and have rough idle

Last edited by bimmere30; 06-25-2014 at 06:25 PM.
bimmere30 is offline   Reply With Quote
Old 06-25-2014, 06:18 PM   #10
DIY
Permanently Dirty
 
DIY's Avatar
 
Join Date: Aug 2010
Location: Etobicoke
Posts: 528
I bet its your o2... But as already asked, how rich are you running? Irratic idle could be a vacuum leak... Clean your icv?
__________________

Last edited by DIY; 06-25-2014 at 06:30 PM.
DIY is offline   Reply With Quote
Old 06-25-2014, 06:19 PM   #11
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,363
well, it looks like its gonna be process of elimination. start swapping out parts. remember, certain parts are hard to come by... disconnect the AFM and see how the car runs.

some of things you can start checking:

air intake leaks

fuel injectors clogged or not opening

fuel pressure to low

air flow sensor flap binding

coolant temp sensor faulty or faulty wiring

throttle switch incorrectly adjusted or faulty

idle mixture incorrectly adjusted

idle speed control system faulty

incorrect ignition timing

poor fuel quality- water in fuel

cold start system operating all the time

faulty L-Jetronic or Motronic control unit (DME)
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!

Last edited by Ceeker; 06-25-2014 at 06:29 PM.
Ceeker is offline   Reply With Quote
Old 06-26-2014, 12:22 PM   #12
bimmere30
2nd Gear Member
 
Join Date: Aug 2012
Location: GTA
Posts: 130
Quote:
Originally Posted by Ceeker View Post
well, it looks like its gonna be process of elimination. start swapping out parts. remember, certain parts are hard to come by... disconnect the AFM and see how the car runs.
(DME)
I disconnected the AFM, all it does is idle at high rpm at 2000
bimmere30 is offline   Reply With Quote
Old 06-26-2014, 12:05 AM   #13
Slowered318
Stuck in the 90's
 
Slowered318's Avatar
 
Join Date: Jan 2002
Location: Toronto
Posts: 6,007
Seriously (and because I've been told this many times) your best solution is simple... two words.
1. Motor
2. Swap
Slowered318 is online now   Reply With Quote
Old 06-26-2014, 12:11 AM   #14
Ceeker
Parts hoarding partner...
 
Ceeker's Avatar
 
Join Date: Nov 2007
Location: Toronto
Posts: 3,363
Quote:
Originally Posted by Slowered318 View Post
Seriously (and because I've been told this many times) your best solution is simple... two words.
1. Motor
2. Swap
some take longer to get around to it.
__________________

I think I've had 14 bmw's in 4 years.
2 IX's -sold and parts
2 325i 4 dr - sold
4 318is all white - sold and parts
1 87 325is red - parts
1 89 325i vert grey - parts
1 90 325is white - keepin
1 87 325i vert -red - keepin
latest addition 1 88-325is red - parts
latest addition 1 89-325i vert - white -fixin/sold
latest addition 1 92-318i vert - blue - parts
latest addition 1 87 325is blk - parts.

latest addition as of 2013-Gold 87-325is auto! it's a keeper!
Ceeker is offline   Reply With Quote
Old 06-26-2014, 04:00 AM   #15
Slowered318
Stuck in the 90's
 
Slowered318's Avatar
 
Join Date: Jan 2002
Location: Toronto
Posts: 6,007
Quote:
Originally Posted by Ceeker View Post
some take longer to get around to it.
I had it running pretty good last year, the BMW gods shone some light on me. This summer is ticking, rattles and a strange loss of HP. 13 years and a couple thousand dollars has taught me the M42 is relentless with issues.

Last edited by Slowered318; 06-26-2014 at 04:02 AM.
Slowered318 is online now   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:23 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.