Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > X series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-01-2013, 07:22 PM   #1
xrayboy
1st Gear Newbie
 
Join Date: Dec 2004
Location: ontario
Posts: 8
Problems after disconnecting battery

Hello. I disconnected the battery in my 2001 X5 when removing steering wheel to rapair the BC button. The BC button now works but when I turn the key to run the horn blasts on/off. the car will start but i have extra lights on the dash. The parking brake light stays on yellow (red if i pull the lever) the abs light stays on, and the stability control light stays on as well. The remote still works to turn the alarm on/off and unlock/lock doors.

I called a dealership and a mechanic said there could be a voltage imbalance between the car battery and alarm battery. He suggested putting a charger on battery but that didnt fix anything.

I have tried connecting battery with key in run position, no fix.

Everything worked fine before I disconnected the battery. Does anyone know what I have to do to fix this?

Dan
xrayboy is offline   Reply With Quote
Old 06-05-2013, 01:10 AM   #2
MountainMoto
1st Gear Newbie
 
Join Date: Jun 2013
Location: Canada
Posts: 2
Kind of sounds like a short to ground. Recheck all your work near battery and steering wheel.
MountainMoto is offline   Reply With Quote
Old 06-05-2013, 01:12 AM   #3
MountainMoto
1st Gear Newbie
 
Join Date: Jun 2013
Location: Canada
Posts: 2
Also this sounds funny but try opening and closing all doors including hood and trunk then cycling your key fob locks on and off then put key in and turn to start.
MountainMoto is offline   Reply With Quote
Old 06-06-2013, 09:15 AM   #4
MANDD
Autobahn East
 
Join Date: Jul 2005
Location: Ajax
Posts: 261
Common on the X5 when the battery is disconnected and the alarm siren battery runs low on charge.

After reconnecting the battery and disarming the alarm (usually goes off when reconnecting), turn the key to position 1.

On the cluster 4.4 or MID 3.0 you will see the display counting down about 10 mins.

Sit inside until the countdown ends. Once the count down ends start the engine, it will be fine after this.

If unsuccessful the first time then try again, but unhook the battery first and wait exactly 2 minutes. Reconnect and go through the procedure again.

Mark.
MANDD is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.