Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 5 series
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-03-2012, 11:09 PM   #1
kamalsa
1st Gear Newbie
 
Join Date: Oct 2012
Location: Mississauga, ON
Posts: 2
E60 error: fault in passenger-restraint system affecting airbag

Hello everyone,

I bought a 2004 545i a few days ago, the car is in amazing condition and has 120,000km on it. Today I drove it, parked it at my friends place and just when I was about to leave I turned the car on and this warning came on "fault in passenger-restraint system affecting airbag, belt tensioner, or belt-force limiter. Continue to wear the safety belt" I'm just wondering if anyone has had this issue before and or know anyone that can fix it. I'm trying to avoid the dealership. Any help would be very much appreciated. Thanks in advance.
kamalsa is offline   Reply With Quote
Old 11-04-2012, 12:57 AM   #2
Barnsdale
2nd Gear Member
 
Barnsdale's Avatar
 
Join Date: Dec 2011
Location: Toronto
Posts: 237
Well if you're looking for a good indy mechanic check out RMP Motors, I personally haven't used them but they go recommended on here and I believe they're pretty close to Mississauga. You can do a search and find some reviews of them on here, they specialize in BMW and tons of members on here go there.

Hopefully you can have this issue resolved soon!
Barnsdale is offline   Reply With Quote
Old 11-04-2012, 11:55 AM   #3
Dinanstu
3rd Gear Member
 
Join Date: Dec 2011
Location: Toronto, Canada
Posts: 332
RMP is in etobicoke and Bimmersport is in that neck of the woods too. They should have the proper diagnostic equipment you'll need to read the SRS codes.
__________________
Now for the supercharger....
Dinanstu is offline   Reply With Quote
Old 11-04-2012, 12:17 PM   #4
Blackedout95
5th Gear Member
 
Join Date: Feb 2009
Location: Canada
Posts: 1,083
seat belt buckle.
__________________
E46
Blackedout95 is offline   Reply With Quote
Old 12-01-2012, 10:45 PM   #5
Smallfrie
1st Gear Newbie
 
Join Date: Jan 2010
Location: Ontario
Posts: 16
There's a recall for that problem but it is vin specific however if you call your dealership and ask them if you can bring your car in for the 10 year passenger seat mat sensor restrain system. It is a very common problem and i myself have it done under warranty. Goodluck!

Thread on this recall here: http://forums.5series.net/e60-discus...recall-122566/

Last edited by Smallfrie; 12-01-2012 at 10:47 PM. Reason: more information added
Smallfrie is offline   Reply With Quote
Old 12-03-2012, 09:06 PM   #6
mechanic55
1st Gear Newbie
 
Join Date: Dec 2012
Location: Fonthill, Ontario
Posts: 1
Quote:
Originally Posted by kamalsa View Post
Hello everyone,

I bought a 2004 545i a few days ago, the car is in amazing condition and has 120,000km on it. Today I drove it, parked it at my friends place and just when I was about to leave I turned the car on and this warning came on "fault in passenger-restraint system affecting airbag, belt tensioner, or belt-force limiter. Continue to wear the safety belt" I'm just wondering if anyone has had this issue before and or know anyone that can fix it. I'm trying to avoid the dealership. Any help would be very much appreciated. Thanks in advance.
Just went through this. It's the sensor mat in the passenger seat. 10 year extended warranty from date of manufacture. I have the comfort seats. Kept the car overnight, updated car programming which incidentally cleared up a few other issues such as transmission surge, gas cap check light and improved throttle response. Was even given a new loaner. Zero charge.
mechanic55 is offline   Reply With Quote
Old 01-11-2014, 02:15 PM   #7
Allyox
Allyox
 
Join Date: Oct 2013
Location: Canada
Posts: 6
Where did you go to get this work done? I have the same issue? And I live in ontario!
Allyox is offline   Reply With Quote
Old 01-12-2014, 07:36 PM   #8
cmyachtie
FDF545i
 
Join Date: Dec 2013
Location: Halifax
Posts: 7
I have been having this same issue for the last few weeks now and my dealer says that the mat refit was done already and it seems to be the front sensors, anyone know where exactly these are located?
I have been getting this fault showing up lately and it occurred when parked car in the rain overnight (normally she in garage)twice sofar I cleared error myself and all was well again, drove for two weeks and now same message is back again:

Battery cable refit and seat sensor mat recall was performed some time ago I was told by dealer, so assuming that is not it it will likely be the sensor(s)...

Does NE1 have any idea where these sensors are located?
Below is the fault readout:
E R R O R M E M O R Y
---------------------------------------
Date: 08.01.2014 17:39:24
ECU: SGM_60_2
JobStatus: OKAY
Variant: SGM_60_2
-------------------------------------------------------------
RESULT: 3 error in error memory !
-------------------------------------------------------------
9403 UpFront-Sensor right defective
Error counter: 17
Mileage 75096 km
System time begin of error 1852.86 hours
System time end of error 1854.39 hours
No matching error symptom
Test conditions fulfilled
Error not present now, but already stored
Error would not cause a warning lamp to light up
Error classification t > 1min
Error classification 1s < t < 1min
Error classification 0 < t < 1s
Error code: 94 03 20 E0 11 24 AB 00 06 36 53 00 06 37 A3
-------------------------------------------------------------
9404 Upfront-Parameter inconsistent
Error counter: 18
Mileage 75096 km
System time begin of error 1852.88 hours
System time end of error 1854.39 hours
No matching error symptom
Test conditions fulfilled
Error not present now, but already stored
Error would not cause a warning lamp to light up
Error classification t > 1min
Error classification 1s < t < 1min
Error classification 0 < t < 1s
Error code: 94 04 20 E0 12 24 AB 00 06 36 58 00 06 37 A2
-------------------------------------------------------------
9402 UpFront-Sensor left defective
Error counter: 7
Mileage 75112 km
System time begin of error 1853.41 hours
System time end of error 1854.22 hours
No matching error symptom
Test conditions fulfilled
Error not present now, but already stored
__________________

2004 545i, adaptive xenons, adaptive steering, 74Kkms
1998 E39 528i 5spd man. with 340Kkms..when sold and still going
1986 E30 Msport with over 300Kkms sold
1998 328i in Munich for 3 yrs..sold.
cmyachtie is offline   Reply With Quote
Old 01-22-2014, 06:03 PM   #9
cmyachtie
FDF545i
 
Join Date: Dec 2013
Location: Halifax
Posts: 7
UPDATE:
Cleared the faultcodes twice now after having car parked overnight in the rain and that is when I seem to get the errors popping up, never had it while driving in rain, so I suspect there must be some water infiltration going on and suspect the sunroof drains but will have to check them later when weather improves for me.

Quote:
Originally Posted by cmyachtie View Post
I have been having this same issue for the last few weeks now and my dealer says that the mat refit was done already and it seems to be the front sensors, anyone know where exactly these are located?
I have been getting this fault showing up lately and it occurred when parked car in the rain overnight (normally she in garage)twice sofar I cleared error myself and all was well again, drove for two weeks and now same message is back again:

Battery cable refit and seat sensor mat recall was performed some time ago I was told by dealer, so assuming that is not it it will likely be the sensor(s)...

Does NE1 have any idea where these sensors are located?
Below is the fault readout:
E R R O R M E M O R Y
---------------------------------------
Date: 08.01.2014 17:39:24
ECU: SGM_60_2
JobStatus: OKAY
Variant: SGM_60_2
-------------------------------------------------------------
RESULT: 3 error in error memory !
-------------------------------------------------------------
9403 UpFront-Sensor right defective
Error counter: 17
Mileage 75096 km
System time begin of error 1852.86 hours
System time end of error 1854.39 hours
No matching error symptom
Test conditions fulfilled
Error not present now, but already stored
Error would not cause a warning lamp to light up
Error classification t > 1min
Error classification 1s < t < 1min
Error classification 0 < t < 1s
Error code: 94 03 20 E0 11 24 AB 00 06 36 53 00 06 37 A3
-------------------------------------------------------------
9404 Upfront-Parameter inconsistent
Error counter: 18
Mileage 75096 km
System time begin of error 1852.88 hours
System time end of error 1854.39 hours
No matching error symptom
Test conditions fulfilled
Error not present now, but already stored
Error would not cause a warning lamp to light up
Error classification t > 1min
Error classification 1s < t < 1min
Error classification 0 < t < 1s
Error code: 94 04 20 E0 12 24 AB 00 06 36 58 00 06 37 A2
-------------------------------------------------------------
9402 UpFront-Sensor left defective
Error counter: 7
Mileage 75112 km
System time begin of error 1853.41 hours
System time end of error 1854.22 hours
No matching error symptom
Test conditions fulfilled
Error not present now, but already stored
__________________

2004 545i, adaptive xenons, adaptive steering, 74Kkms
1998 E39 528i 5spd man. with 340Kkms..when sold and still going
1986 E30 Msport with over 300Kkms sold
1998 328i in Munich for 3 yrs..sold.
cmyachtie is offline   Reply With Quote
Old 01-13-2014, 01:31 AM   #10
windwagen
6th Gear Member
 
windwagen's Avatar
 
Join Date: Jul 2004
Location: Markham
Posts: 1,916
I had this problem on my E39... Apparently it's quite a common problem and many people bypass it. E39s wouldn't have this 10 year warranty.... I see that the same bypass can be used for E60...

FYI....

http://www.ebay.co.uk/itm/FITS-BMW-P...ht_3519wt_1255

Btw - I scanned my car and it showed unoccupied with the bypass installed.... no faults though. Seller (not the link above) says that's not right... so I'm getting a replacement.
windwagen is offline   Reply With Quote
Old 01-23-2014, 05:25 PM   #11
windwagen
6th Gear Member
 
windwagen's Avatar
 
Join Date: Jul 2004
Location: Markham
Posts: 1,916
Got a replacement bypass from a different vendor.... same thing! ....shows as unoccupied... this sucks!
windwagen is offline   Reply With Quote
Reply

Tags
belt force limiter, belt tensioner, e60 error, restraint system

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014