Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E46 (1998 - 2005)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-27-2012, 06:18 PM   #1
emerica55
1st Gear Newbie
 
Join Date: Nov 2011
Location: montreal
Posts: 3
HELP ELM DSC and SES( CHECK ENGINE)

OK! my car is an e46 m3 with 100miles ! the car was running great before i change my thermostat.! Once i restart the car , the light ELM, DSC and SES came up!.. i try to see if i dont replug the TPS, but yes he his. i check also all connector, but all look ok.

I dont know what to check! but my car cant run like that! anyone have idea what can i check??? ( my obd2 reader dont read the code for the check engine on an e46 m3 2001)

plz help me!

Phil
emerica55 is offline   Reply With Quote
Old 04-01-2012, 08:55 PM   #2
nab24-
2nd Gear Member
 
Join Date: Feb 2012
Location: Keswick
Posts: 103
bring it in to have it diagnosed? thats what i do im also not super handy or pateint when it comes to cars, good luck, hope you fixed it
__________________
Adrenaline is my DRUG, Speed is my PASSION, Racing is my LIFE!
nab24- is offline   Reply With Quote
Old 04-02-2012, 07:53 AM   #3
emerica55
1st Gear Newbie
 
Join Date: Nov 2011
Location: montreal
Posts: 3
Quote:
Originally Posted by nab24- View Post
bring it in to have it diagnosed? thats what i do im also not super handy or pateint when it comes to cars, good luck, hope you fixed it
Yeah , I buy an descent obd2 reader, and the come mean TPS SENSOR. The pin who supposed to enter into the tps sensor was broke. I bought an other throttle body for the cylinde 1. My car run great now
emerica55 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:12 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.