Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > General > General Discussion
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-09-2010, 11:55 PM   #1
againstallodds
2nd Gear Member
 
Join Date: Sep 2003
Location: toronto
Posts: 122
aa rotrex c30 supercharger

hey guys, its confirmed that my s/c is done!! aa wants 2500 just for a replacement blower, i say no thanks. before i make any decisions on what to do..does anyone know someone or a place that will rebuild this supercharger?? preferably in the toronto/brampton/mississauga area. let me know, your help is greatly appreciated!
againstallodds is offline   Reply With Quote
Old 08-10-2010, 12:11 AM   #2
Bliss
Administrator
 
Join Date: Dec 2001
Location: Burlington, On
Posts: 3,322
Wow, sorry to hear about your loss. Since AA is leaning all their kits towards the HKS blowers, that might be a good reason why they want so much. Did you try contacting Rotrex direct and ask if they can either direct you to a rotrex supplier, or have them ship you a rebuild kit? I'm actually quite surprised that AA didn't offer you better assistance other than trying to sell you a new sc.

What exactly happened?
__________________


For maXbimmer decals, please email info@maxbimmer.com
Bliss is offline   Reply With Quote
Old 08-10-2010, 12:37 AM   #3
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,675
Send a message via MSN to propr'one
what's wrong with the blower? if its jsut the bearing its like 400$ from http://www.superchargerrebuilds.com/
__________________
d1s bulb canada[/size]
Hot: 2001 Estoril M Roadster ZCP 19's, ZHP knob, JL 8W3
Hot: 2013 Black Ninja 300 ABS Leo Vince Carbon pipe
Cold: 2002 TiAg M3 6mt ZCP 19's supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 08-10-2010, 08:43 PM   #4
againstallodds
2nd Gear Member
 
Join Date: Sep 2003
Location: toronto
Posts: 122
thanks propr'one...id rather not send it to texas? but if anyone has deal with supercharger rebuilds and liked their experience..im interested to hear from you...let me know thanks.
againstallodds is offline   Reply With Quote
Old 08-10-2010, 09:00 PM   #5
Bliss
Administrator
 
Join Date: Dec 2001
Location: Burlington, On
Posts: 3,322
You still never answered our question as to what happened, and what makes you or AA think you need a new blower? Spun bearing, leaking, broken turbine, broken shaft?

Anyways, if it's a matter of rebuilding then order the rebuild kit from the site that Propr'one linked and if you're somewhat mechanically inclined then tackle the job yourself, if not, then call up one of the techs that sponsor this site, and im sure one of them can help you out.
__________________


For maXbimmer decals, please email info@maxbimmer.com
Bliss is offline   Reply With Quote
Old 08-10-2010, 09:11 PM   #6
againstallodds
2nd Gear Member
 
Join Date: Sep 2003
Location: toronto
Posts: 122
its very loud if that helps.
againstallodds is offline   Reply With Quote
Old 08-10-2010, 09:36 PM   #7
Bliss
Administrator
 
Join Date: Dec 2001
Location: Burlington, On
Posts: 3,322
Quote:
Originally Posted by againstallodds View Post
its very loud if that helps.
If you take the belt off and spin the pulley, does it still make noise? This is a good way to test if its in fact your sc thats faulty, but i'm guessing you already know it is. My guess it's most likely due to overheat. Possibly no oil getting to it, or was low. If you're confident enough to take it apart yourself check for the inside metal components being a black/burnt color. This would indicate that you ran on low oil, and was just burning it off. It could be your bearings that are gone if its noisy, but it really can be anything. I would still do a complete rebuild, and make sure to check your cooling lines afterwards to make sure it's being fed oil. Good luck.
__________________


For maXbimmer decals, please email info@maxbimmer.com
Bliss is offline   Reply With Quote
Old 08-10-2010, 11:41 PM   #8
againstallodds
2nd Gear Member
 
Join Date: Sep 2003
Location: toronto
Posts: 122
i dont think oil getting to it was the case...oil is being fed. thanks alot for our insights though bliss...
againstallodds is offline   Reply With Quote
Old 12-13-2010, 06:15 PM   #9
ckhmarston
1st Gear Newbie
 
Join Date: Dec 2010
Location: hawaii
Posts: 1
I am really bummed out, my C30 just started running very loud, so i checked the oil lines, which seemed to be pumping enough through the return line...then i pulled of the belt and sure enough the S/C was not turning smoothly like i was hoping for. However i did get a better quote from URD for a S/C than $2500. if anyone has knows for sure that this is a clear sign of a bad bering please let me know....

thanks
ckhmarston is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:58 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.