Click to go to Forum Home Click to go to maXbimmer Home

Go Back   maXbimmer Forums > maXimum Tech > 3 Series > E30 (1983 - 1991)
User Name
Password


Welcome to Maxbimmer.com!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-10-2008, 06:38 PM   #1
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,714
Send a message via MSN to propr'one
Why did my e30 not start and then start working fine?

I drove 1500km this weekend (and got pulled over doing 152 km/h, yay), parked the car yesterday, took a nap, went to start it, wouldn't start. Swapped the ECU (known issue on my car) still wouldn't start. Gave up, went to sleep.

woke up today, works great. Swapped the ECU, (just for fun), let it adapt, runs great.

What could it be? it always cranked, just didn't start. I want to fix this as i need this car to be (reasonably) reliable
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 11-10-2008, 06:38 PM   #2
mirek
6th Gear Member
 
mirek's Avatar
 
Join Date: Nov 2003
Location: Canada
Posts: 5,454
fuel pump?
mirek is offline   Reply With Quote
Old 11-10-2008, 07:05 PM   #3
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,995
It can be a LOT of things, but when it happens again, try to find out if you are missing fuel or spark. That will simplify things a bit....

Some of the things that can work on and off are; fuel pump, sensors (crank, position, etc...) relays (several), fusable links (not fully blown, but bad connection), ECU, wiring...

Also i found my old E30 needed good electrical power to start, eg; wont start, but starts if boosted....
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 11-10-2008, 06:58 PM   #4
zackman17
Banned
 
Join Date: Apr 2008
Location: Toronto
Posts: 850
Quote:
Originally Posted by propr'one View Post
I drove 1500km this weekend (and got pulled over doing 152 km/h, yay), parked the car yesterday, took a nap, went to start it, wouldn't start. Swapped the ECU (known issue on my car) still wouldn't start. Gave up, went to sleep.

woke up today, works great. Swapped the ECU, (just for fun), let it adapt, runs great.

What could it be? it always cranked, just didn't start. I want to fix this as i need this car to be (reasonably) reliable
identicle problem ii took off the hose at the pump and turned over the engine and no gas. so i turned the connector going into the pump, turned over the engine and i was getting gas
zackman17 is offline   Reply With Quote
Old 11-10-2008, 07:36 PM   #5
T.Dot_E30
Classifieds Moderator
 
T.Dot_E30's Avatar
 
Join Date: Apr 2003
Location: T.Dot
Posts: 9,386
When you say wouldn't start, what was it doing?

Was it cranking? As fil said, check for fuel and spark. Then go from there.
__________________
T.Dot_E30 is online now   Reply With Quote
Old 11-10-2008, 07:52 PM   #6
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
I would wager fuel pump relay. Its one of the orange ones under the cover by the intake. If it happens again, swap the two orange ones; the other is the O2 sensor heater. If it starts right away, get a new one!

That's where I'd start anyway.

Has the fuel pump been making any noise?
__________________
everlast is offline   Reply With Quote
Old 11-10-2008, 07:56 PM   #7
slimjim
Almost Sideways
 
Join Date: Nov 2007
Location: canada
Posts: 1,876
^^^or jump it..jump 30 and 89 i think, lol check to make sure
__________________
slimjim is offline   Reply With Quote
Old 11-10-2008, 08:03 PM   #8
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,714
Send a message via MSN to propr'one
It was cranking and turning over, just not starting. I'm guessing fuel pump relay also. Can't get it to not start again, it starts every time now
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 11-10-2008, 08:04 PM   #9
everlast
if I lived . I would be ~
 
everlast's Avatar
 
Join Date: Mar 2004
Location: Ottawa
Posts: 5,847
Relay's tend to fail at different temperatures. Wait until it gets fully cold again and see if it cacks.
__________________
everlast is offline   Reply With Quote
Old 11-10-2008, 08:08 PM   #10
Chris de la Cruz
sex, drifting & punk rock
 
Join Date: Sep 2003
Location: markham
Posts: 5,668
Send a message via MSN to Chris de la Cruz
welcome to the world of owning an e30
__________________
www.CSCS.ca
Chris de la Cruz is online now   Reply With Quote
Old 11-10-2008, 08:39 PM   #11
Eurostyle
MaXsponsor
 
Eurostyle's Avatar
 
Join Date: Feb 2002
Location: Milton
Posts: 14,995
Quote:
Originally Posted by Chris de la Cruz View Post
welcome to the world of owning an e30
I would say my first ETA was the most reliable car i ever owed...over 4-5 years of abuse, i only did a water pump, and ball joints...The rest was all regular maintenance and mods....Oh and i blew a rad hose, after using it to tow a dolly with a car on it...but that was the original hose from 1985 with 400K on it...lol
__________________
BIMMER HEAVEN
Specialized in BMW recycling, all OEM used parts
Up to 90% off new cost!!!
Most models E30 E36 E46 E90 E92 E93 E34 E39 E60 E32 E38 E65 E66 X3 X5 M3 M5 Z4


2nd location opening SOON!!!!

Call 11-8PM 416 821-2578
New inventory daily. 50+ cars in stock!
Eurostyle is offline   Reply With Quote
Old 11-10-2008, 08:14 PM   #12
slimjim
Almost Sideways
 
Join Date: Nov 2007
Location: canada
Posts: 1,876
^lol ya, by 2-3 years i can safely say ull get to know every bolt in ur car.
__________________
slimjim is offline   Reply With Quote
Old 11-10-2008, 08:57 PM   #13
sic///M
4th Gear Member
 
Join Date: Mar 2005
Location: nowhere
Posts: 777
+1 for fuel pump, had the same issue on my cabrio
sic///M is offline   Reply With Quote
Old 11-10-2008, 10:19 PM   #14
propr'one
op sucks cock
 
propr'one's Avatar
 
Join Date: Jun 2004
Location: T.
Posts: 17,714
Send a message via MSN to propr'one
the car was on E when it didn't want to start, now its on full and starts every time.
__________________
d1s bulb canada

Hot: 2001 Estoril M RoadsterZCP 19's michelin supersports, ZHP knob, JL 8W3
Cold: 2002 TiAg M3 6mt ZCP 19's michelin supersports, deoranged, dechromed, led tails, ZHP knob, UUC SS v3, GROM, OEM 18's w310's,
hid headlights hid kit
propr'one is offline   Reply With Quote
Old 11-10-2008, 10:52 PM   #15
El Gato Liso
6th Gear Member
 
El Gato Liso's Avatar
 
Join Date: May 2007
Location: Brampton
Posts: 3,110
Quote:
Originally Posted by propr'one View Post
the car was on E when it didn't want to start, now its on full and starts every time.
Mr. One man all i can say is LOL
__________________
R.I.P. E30
El Gato Liso is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:25 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.