View Single Post
Old 07-08-2013, 11:12 AM   #1
eclipsemyl
1st Gear Newbie
 
Join Date: Nov 2008
Location: Ontario
Posts: 3
Battery light flashing after turning off engine

Hi folks,

Last week my alternator crapped out (battery light came on, radio turning off and on by itself, battery died, etc). Checked the voltage of battery after charging and it was normal (around 12.6v) and checked voltage when car was running (around 11v).

Took to Crappy Tire (no other place local to me at the time...was in parents' hometown stuck there) and got it replaced with a "Champion" branded remanufactured alternator. Also, they did do an AVR test to confirm the alternator was bad.

It's been working fine so far, but I notice that after I turn the car off and then put the key back into the accessory position that the battery light sometimes flashes off and on (this is with the car no longer running).

It doesn't do this every time, but I've noticed it a few times. I did put the voltmeter on it last night to check the voltage and usually it was stable around 12.6v in this position. But actually I did notice it did spike once or twice (into the 14s I believe), but I haven't really noticed it since. Also, I've been running the car in test mode with the voltage showing on the dash before, during, and after I drive. All is normal (around 12.5v with engine off and around 13.9v with engine running).

All seems to be working fine, but it was a little bit concerning that the battery light was flashing with the key in the accessory position with the car off. I suppose I don't really need to worry about it unless there's an issue with the car actually running (or trying to start the car).

Any ideas why it flashes when in the accessory position? Any concerns?

Thanks in advance.
eclipsemyl is offline   Reply With Quote