View Single Post
Old 04-11-2011, 10:14 AM   #60
sb_600
5th Gear Member
 
sb_600's Avatar
 
Join Date: Apr 2010
Location: Ottawa, ON
Posts: 1,197
I bit of progress was made this weekend, but not as much as I had hoped.

I had the day off work on friday and the plan was to get the engine back in the car. I had removed the front subframe earlier in the week, welded in engine mount reinforcement tabs, and repainted it. I then reinstalled it with new M3 control arms to increase the caster. I also took the opportunity to clean the steering rack and install new inner & outer tie rods (old ones were seized). My new solid AKG engine & transmission mounts had arrived last week as well and they were bolted on too.

The engine was pretty much ready for the flywheel/clutch/transmission. After installing the flywheel, thankfully I checked and noticed that the crankshaft didn't have a pilot bearing! It wasn't in stock at Otto's BMW so the engine work was stopped there for the weekend. I still got a few other things done though, and I helped Chris with his engine (my old M50NV) - you can see what we did (if you haven't already) in his build thread. That engine is in such better shape than my M52 was when I pulled it apart!

I NEED to have the engine running next weekend. The weekend after that is Easter, and the weekend after that is the test and tune at Picton! It's going to be close. I'll be spending evenings this week installing the engine, transmission and exhaust.
__________________
Shawn
1992 BMW 325i (CHUMPCAR #296 - Metric Homes Racing)
1992 3.0L M52 325i (ex-daily driver - track car only)
2002 330Ci (ex-daily driver - sold!)

sb_600 is offline   Reply With Quote