maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E30 (1983 - 1991) (http://www.maxbimmer.com/forums/forumdisplay.php?f=58)
-   -   Possible e30 Battery drain sources (http://www.maxbimmer.com/forums/showthread.php?t=28194)

BMW BMXer 02-02-2004 02:48 PM

Possible e30 Battery drain sources
 
I parked my car Friday at 5pm. Went to drive sunday morning for work it was dead. Boosted drove to work. (12am) got out of work 5pm. Dead again.

This morning went to check.. guess what dead again (neighbours all at work, mom not home ****ED).

What could be draining my battery? I just got it tested at crappy tire and they said it checked as "Good" but 50% charge.

Slowered318 02-02-2004 02:55 PM

Heated mirrors might be staying on, donno how but i had that happen before.

Maybe your battery is no good and won't hold a charge in the cold weather or your alternator is screwed (check if its a valao, if so swap for a bosch)

The cold causes many electrical issuses.. maybe it's not charging enough because when you drive it you have the heater fan on, defrost, heated seats, headlights, power this, power that. all on at the same time, and the alternator only supplys 40-60 amps?

pull the battery inside for the night and completely slow charge it and let it warm up real nice..

BMW BMXer 02-02-2004 03:07 PM

I drove around yesterday with NOTHING on but headlights. I was freezing like a mother ****er and listening to all the weird sounds my car makes.

The alts a bosch. But the belts could use a tighten. I hate lying on cold concrete. And I cant fix it till after school tomarrow because of time and so on.

Oh and slowered I dont have a battery charger.

Jase 02-02-2004 03:39 PM

Is your battery indicator light work?.I dont think the car will charge if it is burned out.

BLAGUSS 02-02-2004 03:45 PM

Quote:

Originally posted by Jase
Is your battery indicator light work?.I dont think the car will charge if it is burned out.
are you talking about one little green light?
I think i have it on my battery all the time on.

I hope it's not alternator .

Jase 02-02-2004 05:11 PM

no there is a light in the instrument panel that looks like a battery. It is a red light

BMW BMXer 02-02-2004 06:02 PM

You mean the one beside the oil light? Ya it works.

Jase 02-02-2004 06:05 PM

ok. My battery would not charge because that light was out. Sounds stupid but I was told thats how bmw's are. Well you can strike that out for being the problem.

BMW BMXer 02-02-2004 06:27 PM

So far I have striked out.
glove box light
door open lights
trunk lights
battery light

Tomarrow I get the battery tested. Maybe my system hosed it.

Jase 02-02-2004 09:52 PM

make sure your terminals are not shot. the ones attached to the car that is.

BMW BMXer 02-02-2004 09:57 PM

How do I know if those are shot?

Jase 02-02-2004 11:32 PM

if they are all chewed up looking. You can clean them with a wire brush. Make sure where the wires are connected it has a good connection. sometimes the aluminum gets corrouded

BMW_M52_M20 02-03-2004 12:32 AM

Could be something to do with your system, make sure your remote wire is properly connected to the deck to the amp to make sure it is cutting off the power to the amp when the car is off.........

Otherwise, I think it may be the alternator......do your lights dim when sitting at idle and then brighten up when you hit the gas? Sounds like you need a new battery, the cold weather makes a semi pooched battery worse. I just replaced mine and the difference in cranking amps is amazing. I have no problems starting my car now.......
Jay

BMW BMXer 02-03-2004 01:56 AM

My battery is a year old. I figure tomarrow after school I will get the battery tested. Tighten my alternator belt. Clean the terminals and hope for the best.

No homework for me.

Lil'Smoothie 02-03-2004 02:01 AM

Quote:

Could be something to do with your system, make sure your remote wire is properly connected to the deck to the amp to make sure it is cutting off the power to the amp when the car is off.........
that will definitely cause a slow drain, I had the same problem and it was something todo with the remote wire and my amp creating a constant drain

but if your belts are loose in this cold weather that could be your problem

if not I'd have your alternator checked out


All times are GMT -4. The time now is 10:08 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.