maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E30 (1983 - 1991) (http://www.maxbimmer.com/forums/forumdisplay.php?f=58)
-   -   e30 cluster help (http://www.maxbimmer.com/forums/showthread.php?t=157399)

TSI 05-03-2013 03:21 PM

e30 cluster help
 
One more step towards driveability...
I'm trying to reinstall the cluster in the E30 cab, after changing the SI board batteries (fingers crossed). At some point in the car's history, someone hacked up the cluster trim and completely messed it up (lost some screws, used some longer ones and broke the SI board housing.


However, I can't seem to fit the cluster back in. On the driver's side, there appears to be a metal tube of some kind which prevents the cluster from reaching the necessary position (where the screws would line up). I've wrestled with it for three hours, to no avail. Is there something I'm missing here?

TSI 05-04-2013 11:25 AM

Cluster is in, but not fitting right...impossible to get the screws into the bottom corners.

frankie591 05-04-2013 06:02 PM

pics might help. I can't really picture what the issue is.

Ceeker 05-04-2013 09:06 PM

you really gotta get someone with more experience to work on your car Matt. LOL..

Bring the car by my place and we'll get it back in. how much you wanna bet I can get it back in??

TSI 05-05-2013 10:13 AM

Well, I gotta build the experience somehow. :)

@frankie: I can't get a camera in there, but the cluster isalmost perfectly in place. Problem is, the bottom left corner is sitting a little high. Reaching behind it from under the wheel, the problem is the blue cluster housing is being wedged against a black metal tube which runs behind the corner of the cluster. It's missing about 2mm clearance, as far as I can tell.


All times are GMT -4. The time now is 09:51 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.