maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   General Discussion (http://www.maxbimmer.com/forums/forumdisplay.php?f=2)
-   -   car loses power (http://www.maxbimmer.com/forums/showthread.php?t=157075)

johnbmw 04-19-2013 12:25 PM

car loses power
 
Just wanted to know if anyone has experienced this issue before.
I have a 2003 xi
Problem:
When accelerating coming out of a turn I lose power and the car idles very rough. I have to turn the car off and restart it.
I had the fuel pump changed and the problem is still there. My mechanic canít seem to find the issue.
My next step is to change the fuel filter. But I donít think this is the issue, because it only happens when pressing hard on the gas.

Thanks all,

BMXWill 04-19-2013 12:27 PM

Long right hand turn with less than half a tank of gas?

johnbmw 04-19-2013 12:32 PM

tank is sometimes full, left or right. sometime when I press on the gas to pass a car it happens.

johnbmw 04-19-2013 12:36 PM

coming to think of it.. it does happen more often on right hand turns and my tank is or maybe half full. I will start monitoring that. why is this something common. It only started a few months ago. I drove the car for 7 years and no issues like this before.

Blades 04-19-2013 02:10 PM

That cant be right .. that would have to be some long hell of a turn. You still have gas in your fuel lines all the way to the engine which would not matter if your turning hard. your injectors are spraying evenly into the engine and there is no way you would spray everything from your lines just going around a corner.

johnbmw 04-19-2013 02:41 PM

thanks, I'll change the fuel filter and see what happens.

BMXWill 04-19-2013 02:46 PM

Doesn't have to be that long of a right turn for fuel starvation, happens on the first turn at TMP. Mind you that is on the track and in an e36. Just putting ideas out there.

NOTORIOUS VR 04-19-2013 02:49 PM

some BMW's have a transfer pump in the tank... so while you might have changed the main pump, it might be the transfer pump causing the issue... but if this happens even with a completely full gas tank I would say you can rule out fuel starvation from the tank.

Does the car run strange at any other point?

johnbmw 04-29-2013 09:23 PM

yes the car is getting worse after the fuel pump change as well. I have to take it to BMW. I have no choice. $$$$$$

if you turn the car off and restart it, it works fine. then the minute you press on the gas too hard it loses power and the car shakes. a restart will clear it once again.

Eurostyle 04-29-2013 11:41 PM

Quote:

Originally Posted by johnbmw (Post 1608349)
yes the car is getting worse after the fuel pump change as well. I have to take it to BMW. I have no choice. $$$$$$

if you turn the car off and restart it, it works fine. then the minute you press on the gas too hard it loses power and the car shakes. a restart will clear it once again.

First, dont take it to BMW, you are just wasting your $$$...
Take it to a GOOD BMW shop, the list of sponsors here, or many others.
If a restart fixes the problem, obviously its something electronic. (a restart will not clean your fuel filter!)

I would look for vacume leaks, sometimes under hard acceleration the engine will move (also check engine mounts!) and a cracked intake boot will suck in air...causing a missfire.

Also check camshaft sensors, they tend to do the same.

And last; doest the check engine light come on? (it should) and have you got it scanned? What regular maintenace have you done in the last 7 years?

Dinanstu 04-30-2013 09:34 AM

Get the codes first (as stated)
It sounds like something is triggering the limp home mode under acceleration. Could be as simple as a TPS. There a few sensors in there for throttle system, I believe.

A good indy will figure it out. The dealer tends to be up to date with current models, get an experienced guy.

Blades 04-30-2013 10:49 AM

Quote:

Originally Posted by BMXWill (Post 1606862)
Doesn't have to be that long of a right turn for fuel starvation, happens on the first turn at TMP. Mind you that is on the track and in an e36. Just putting ideas out there.

if its on the track then fill the gas tank up all the way and try it again .. most likely its the gas swaying over to one side and your giving it.

johnbmw 04-30-2013 11:31 AM

Thanks for the contact Erostyle.

I know what you mean with BMW and $$$. However, its with them now and hopefully after this I can start taking it to mimmer haven. I as soon this gets fixed I'll let everyone know what was the resolution.

johnbmw 04-30-2013 11:42 AM

great advise all. thanks I took them all in to have checked out.

Dinanstu > i had a mazda M3, awesome car! had no issues right up to 767,000 km. the only problem I had with it was. "take off was too slow" but got going after 120 km.
with that.. Sorry I will not trade. lol. what I like about BMW my car is a 2003 and the engine is still powerful. well once this issue gets fixed.

TMR-Carbon 05-01-2013 02:53 AM

Check first. just fixed the problems, don't wait.


All times are GMT -4. The time now is 02:12 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014