maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E30 (1983 - 1991) (http://www.maxbimmer.com/forums/forumdisplay.php?f=58)
-   -   Don't know what drive shaft to use (http://www.maxbimmer.com/forums/showthread.php?t=156695)

Tyman 04-01-2013 07:42 PM

Don't know what drive shaft to use
 
ive got an m52 swapped 318 and have no idea what drive shaft is in it, it vibrates really bad from 30-38 km/h then a bit at 120, the bracket that holds the center bearing is completely broken off on the one side so could that be the problem?

TSI 04-01-2013 08:12 PM

That is likely the problem, but if it's been like that for a while you'll probably have other problems with the driveshaft. Do you have any documentation on the swap? Do you know what tranny is in it?

karmatose 04-01-2013 08:40 PM

I had some driveshaft shake but it was because I had shitty polyurethane transmission bushings that compressed way too much after installation and caused the driveline to be out of alignment at and shake like hell at certain speeds. Swapped driveshafts, guibos and CSBs plus pulled out the diff and inspected it and it still didn't go away.

Just put the new bushings in yesterday (Condor Speed Shop's UHMW bushings) and went for a quick drive. No more vibration. On the up side, I now have a spare everything to do with the driveshaft. Replacing your CSB will likely fix your problem though if it's snapped. Not a fun job, but pretty easy to do.

poolays 04-01-2013 08:46 PM

iwould say either the broken hanger bearing as you mentioned or a broken / distorted flex disc.

cormier 04-04-2013 07:11 PM

Your CSB is probably your issue. Guibo may be a good idea to replace while you do it. You can get a new one at Pelican or from Mike@Maranello (easiest sources). If you measure the overall length of your driveshaft, you can probably find out what its from or at least what you need to replace it with should you need to

matty.dc 04-04-2013 09:52 PM

Quote:

Originally Posted by Tyman (Post 1604143)
ive got an m52 swapped 318 and have no idea what drive shaft is in it, it vibrates really bad from 30-38 km/h then a bit at 120, the bracket that holds the center bearing is completely broken off on the one side so could that be the problem?

Do you know which transmission was used in the swap?

Tyman 04-05-2013 09:36 AM

Quote:

Originally Posted by matty.dc (Post 1604692)
Do you know which transmission was used in the swap?

No idea, how can you tell the difference between the two?

karmatose 04-05-2013 09:50 AM

Well, on the Getrag 260 on the left side of the transmission when mounted near where the slave cylinder goes, you'll see a part number that begins with 260. This part number is also on the ass end of the transmission too.

I'm not sure what to tell you about the Getrag/ZF options that were available in the E36 because of limited exposure to them.

AFAIK, the later Getrag 240 could have also been used as well (likely if your car stared life as a 318is)

Bullet Ride 04-05-2013 10:11 AM

Quote:

Originally Posted by Tyman (Post 1604143)
the bracket that holds the center bearing is completely broken off on the one side so could that be the problem?

I'd say that's definitely the issue.

karmatose 04-05-2013 10:15 AM

Quote:

Originally Posted by Bullet Ride (Post 1604737)
I'd say that's definitely the issue.

... and when you replace it, get one of these. It makes the job SOOOOO much easier (says the guy who did it twice last year). Makes getting the inner race off childsplay.


All times are GMT -4. The time now is 12:14 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.