maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E36 (1991 - 1999) (http://www.maxbimmer.com/forums/forumdisplay.php?f=59)
-   -   ASC+T issue, not blinking (http://www.maxbimmer.com/forums/showthread.php?t=156253)

fold 03-10-2013 05:39 AM

ASC+T issue, not blinking
 
Hello

I've got strange problem with ASC, and cannot find anyone with same issue.
My ASC works well, i've tested it on snow and in rain, but ASC light does not blink while working :(
It's not broken bulb, becouse during igntion control tests it lights.
Also when i turn off ASC it lights.

3er 03-27-2013 08:56 AM

probably a loose wiring on the harness. but if the asc is working why worry about the light blinking?

NOTORIOUS VR 03-27-2013 08:59 AM

I don't think it does blink to be honest... At least I don't remember mine blinking (when I had it)

3er 03-27-2013 09:09 AM

Quote:

Originally Posted by NOTORIOUS VR (Post 1603369)
I don't think it does blink to be honest... At least I don't remember mine blinking (when I had it)

ya it does blink when the rear slips but its super annoying if you ask me. lol

fold 03-27-2013 09:15 AM

Quote:

Originally Posted by 3er (Post 1603367)
probably a loose wiring on the harness. but if the asc is working why worry about the light blinking?

i think it's important. When i drive a car without traction control i can feel when it's loosing traction :P with asc sometimes you don't even feel that it's helping you, especially on straight road during winter.
I like to know when it happens.

Any suggestions what should i check? :confused:
I looked thorough wiring datasheets and looks like there are only two pins connected to ASC light. Where is ASC computer located in E36 Compact?

3er 03-27-2013 09:23 AM

Quote:

Originally Posted by fold (Post 1603375)
i think it's important. When i drive a car without traction control i can feel when it's loosing traction :P with asc sometimes you don't even feel that it's helping you, especially on straight road during winter.
I like to know when it happens.

Any suggestions what should i check? :confused:
I looked thorough wiring datasheets and looks like there are only two pins connected to ASC light. Where is ASC computer located in E36 Compact?

lol i guess so. im not sure where it would be. do you have a bentley manual? if not pm me. what i would check tho is make sure that the harness under the hood, the plug that goes into the asc, is fully plugged in and check for fraying. then work your way to the back of the speedo and check for fraying and that all the wires are ok and in good condition and connected to the harness. sometimes wires can get yanked out of the harness when ppl are trying to remove the speedo.

NOTORIOUS VR 03-27-2013 12:14 PM

Just disable it completely... the E36 TC system sucks anyway

fold 03-27-2013 01:13 PM

Quote:

Originally Posted by NOTORIOUS VR (Post 1603402)
Just disable it completely... the E36 TC system sucks anyway

No way, i like it pretty

Quote:

Originally Posted by 3er (Post 1603381)
lol i guess so. im not sure where it would be. do you have a bentley manual? if not pm me. what i would check tho is make sure that the harness under the hood, the plug that goes into the asc, is fully plugged in and check for fraying. then work your way to the back of the speedo and check for fraying and that all the wires are ok and in good condition and connected to the harness. sometimes wires can get yanked out of the harness when ppl are trying to remove the speedo.

I've got bentley manual. I'll check this
Please look at this manual
http://ru.bavariancar.lv/download.php?id=835
My car is E36 Compact 316i so 4-cylinder engine,
At page 204, 208 you can see ASC light, it is connected ASC control unit by PIN 15 (page 208) and PIN 12 (p. 204). Just thinking that it could one of these pins, one for turned off ASC, which actually works, and one for working (blinking) ASC, which is probably not connected.
Could somone confirm or deny my thoughts?

3er 03-27-2013 04:07 PM

Quote:

Originally Posted by fold (Post 1603409)
No way, i like it pretty


I've got bentley manual. I'll check this
Please look at this manual
http://ru.bavariancar.lv/download.php?id=835
My car is E36 Compact 316i so 4-cylinder engine,
At page 204, 208 you can see ASC light, it is connected ASC control unit by PIN 15 (page 208) and PIN 12 (p. 204). Just thinking that it could one of these pins, one for turned off ASC, which actually works, and one for working (blinking) ASC, which is probably not connected.
Could somone confirm or deny my thoughts?

unfortunately that isn't correct. theres 2 wires coming out of the unit one for the abs light and one for the asc light. you spoke of pin 12 and pin 15 technically there the same wire but on different prods. whats on page 204 is early production and 208 is later production. based on the drawing you need to check the fuses in f21 and f27.

a question i have for you is how do you know the asc is indeed working aside from pressing the button and the asc light comes on.

fold 03-27-2013 04:27 PM

I've checked it on parking lot and even today (not intentional) while going to work.

on parking lot for example i drive straight and then make 90 degrees turn. I feel and even hear that asc is working. It corrects car's path, but of course with too high speed it needs driver corrections. While doing the same without asc car would make a circle.
Second test: on snowy road going straight i press the accelerator pedal to the floor and nothing happens :) car slowly accelerates becouse of asc throttle nearly closed
the same without asc is quite dangeorus, wheels rotate too fast, car goes left or right

third test: diagnostic tool doesnt report any errors

3er 03-27-2013 04:47 PM

Quote:

Originally Posted by fold (Post 1603450)
I've checked it on parking lot and even today (not intentional) while going to work.

on parking lot for example i drive straight and then make 90 degrees turn. I feel and even hear that asc is working. It corrects car's path, but of course with too high speed it needs driver corrections. While doing the same without asc car would make a circle.
Second test: on snowy road going straight i press the accelerator pedal to the floor and nothing happens :) car slowly accelerates becouse of asc throttle nearly closed
the same without asc is quite dangeorus, wheels rotate too fast, car goes left or right

third test: diagnostic tool doesnt report any errors

interesting. well to start with the asc wont throw a dtc. go through the fuses and see if any are blown. from what ive seen on the electrical diagram those 2 fuses are bridged fuse 27 is the actual fuse for the cluster illumination not sure what fuse 21 is but it is coming out of the abs/asc unit.

does your abs work?

fold 03-27-2013 05:13 PM

yes, abs also works

i've already checked fuse 27, as you said it's for instrument panel and it's ok

i'll check fuse 21 and report tomorrow

fold 03-31-2013 02:24 AM

hi

sorry it took so long, it's really cold out there

i've checked all fuses and they aren't broken
i'll try to remove speedo and check connections when it's warmer

3er 04-03-2013 01:39 PM

I spoke to a friend of mine about your problem he suggested that if your fuse is ok then the wiring should probably be ok too. He thinks its your module. He was saying the relay that controls the light is more than likely shot.

Still check your wiring tho just to be safe and then if alls good check all the wiring on the module harness itself.

fold 06-24-2013 03:03 AM

it took me some time but finally i've checked wiring in speedo and everything looks ok.

Now i want to check module wiring but don't know where is it located.
I've checked under driver legs, behing glove-box and didn't find it.

Do you know where is it?


All times are GMT -4. The time now is 01:18 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.