maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   General Discussion (http://www.maxbimmer.com/forums/forumdisplay.php?f=2)
-   -   E46 M3 radio doesnt work (http://www.maxbimmer.com/forums/showthread.php?t=155320)

Nipuna 01-17-2013 04:46 PM

E46 M3 radio doesnt work
 
Hello, as i was driving this morning I wanted to change my radio station but soon realized that none of my radio buttons were responsive, but the radio was running. So at a red light i turned off and then on my engine. Then I was able to turn off my radio, but could not turn it on again!! NONE of my radio buttons work.
Would someone please be able to shine light as to why this is and a possible fix?

My car 2004 BMW M3 - 71000kms
Its OEM radio/GPS

dbworld4k 01-17-2013 05:25 PM

Similar thing happened to me once. Turned out to be a loose/bad battery connection in the trunk.

Nipuna 01-17-2013 05:35 PM

Quote:

Originally Posted by dbworld4k (Post 1595217)
Similar thing happened to me once. Turned out to be a loose/bad battery connection in the trunk.

Really!?? ! Were you able to fix it buy tightening the battery connections in the trunk.

dbworld4k 01-17-2013 05:36 PM

Yup, that's what I stated.

I removed the connector wire and reconnected it. Worked perfectly since.

Nipuna 01-17-2013 05:39 PM

Quote:

Originally Posted by dbworld4k (Post 1595220)
Yup, that's what I stated.

I removed the connector wire and reconnected it. Worked perfectly since.

Thank you very much. I will try it. Really appreciated.

Nipuna 02-15-2013 01:46 PM

Quote:

Originally Posted by Nipuna (Post 1595221)
Thank you very much. I will try it. Really appreciated.

Didnt get a chance to reply on the thread... It turned out to be a loose fuse. And after it was taken out then put back in, it worked perfectly.

Thanks for your help :)


All times are GMT -4. The time now is 03:41 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.