maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   Audio/Sound (http://www.maxbimmer.com/forums/forumdisplay.php?f=35)
-   -   2000 740i dead radio controls, popping speakers! (http://www.maxbimmer.com/forums/showthread.php?t=155233)

Cosmopat 01-13-2013 07:36 AM

2000 740i dead radio controls, popping speakers!
 
Hi everyone, nice looking forum. I just bought a 2000 e39 740i with mk2 radio/nav system. When I start the car the nav screen goes straight to the fm radio screen. The speakers make loud popping/hissing noises. All the buttons on the head unit are dead or inop except the volume control which will make the speaker noise louder or quieter when turned. The steering wheel controls will change the radio station (even though the head unit buttons won't) and volume control seems to work as well. When the display says its picking up a station it still just makes humming popping noises. Has anyone ran into this, I'm thinking I need to change the head unit but was hoping someone has ran into this before. Thanks

740-iLL 01-14-2013 03:12 PM

Could be the DSP, the small little box next to the head unit, where you can adjust the equalizer. When that stops working, everything shuts down.

You may find more info regarding this on Bimmerforums 7 Series subsection as there are a lot more owners, and someone has definitely had this issue and has fixed it.

Another great resource is www.E38.org bookmark it!

Cosmopat 01-14-2013 04:59 PM

Thanks, I'll look there. Mine has mk2 Nav with dsp, it doesn't have the box in the right corner like the non-Nav tape player. Think the dsp amp might cause my issue?


All times are GMT -4. The time now is 01:55 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.