maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E30 (1983 - 1991) (http://www.maxbimmer.com/forums/forumdisplay.php?f=58)
-   -   Squealing Belt (http://www.maxbimmer.com/forums/showthread.php?t=155212)

RedKing 01-11-2013 04:36 PM

Squealing Belt
 
I recently did my timing belt, and I also replaced all the aux belts. Now one of the aux belts is squealing (power steering I think). It is usually only at lower rpm's/speeds and only when there is a load on the car. All the belts are tight so I don't know whats causing this.

Any help would be appreciated, Thanks!!

E36is 01-11-2013 05:54 PM

how old is the belt? if its not new, it could have some glazing on the sides of the belting.

Dinanstu 01-11-2013 06:22 PM

You can spray some belt dressing on the belts while they're running, to see which one is the problem...

L1V3N 1T 01-11-2013 06:24 PM

Was it a v-belt? I ask this cause the width of the belt might not have been the wright one for your car. Some times the jobbers give you a belt that's close but just not wright.

RedKing 01-11-2013 07:27 PM

All the belts are new. I bought all the aux belts from bimmerspecialists, so they should be the correct ones.

davericher20 01-11-2013 07:37 PM

How tight is it? When you press your finger on it there should be 1/4 inch of tension

L1V3N 1T 01-11-2013 11:10 PM

Quote:

Originally Posted by RedKing (Post 1594509)
All the belts are new. I bought all the aux belts from bimmerspecialists, so they should be the correct ones.

That's good to hear. Ya I would be double checking the tension on the belt then.

RedKing 01-12-2013 01:03 PM

I checked the tension on the belts, the a/c and alternator are fine, but the power steering belt is pretty tight. I tried to get a bit more slack on the belt, but I didn't have much luck. The power steering pump didn't move much at all.

Will the squealing stop over time as the belt stretches?

Thanks for all the input!

frankie591 01-12-2013 06:41 PM

squealing is the belt slipping on the pulleys. Usually this is caused because the belt is not tight enough. Try cranking your adjusters and putting some more tension on em.


All times are GMT -4. The time now is 02:53 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.