maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   Quebec/Gatineau/Ottawa (http://www.maxbimmer.com/forums/forumdisplay.php?f=119)
-   -   Help, my fuel pump died! (http://www.maxbimmer.com/forums/showthread.php?t=153160)

Tekals 09-12-2012 02:22 AM

Help, my fuel pump died!
 
As title says, I went to get my hair cut this morning and when I started my car before leaving the parking I noticed that the motor wasnt running as usual.

I tried to rev it up but it it only went to 2000 rpm, so I turned around in the parking lot and parked where it died and did not restart. As I had some problems before with my fuel regulator, I had a permanent pressure gauge installed on my line, and it was barely doing 10psi... and I don't hear the pump prime anymore. Weird part is that it was running perfect on the way there.

I'll try to change it with an older pump assembly I had but I might need a whole assembly as my electrical connections seemed weak!

So if anyone has an fuel pump assembly for a e30 325is 1990, please let me know!

On a unrelated note: my brother just bought a car and needs an inspection for his insurance (because its "modified"). Any places around Ottawa-Gatineau??
Thank you!

Eurostyle 09-12-2012 02:43 AM

I wouldnt call it "weird", when it comes to fuel pumps they work fine until they just stop!
Very rare to see some symptoms before...

Tekals 09-12-2012 09:11 AM

I had problems with my first e30 with the fuel pump, it would run just fine at before hitting 60km/h or 4000 rpm and would not feed enough gas to support the demand.

Anyway, I'm checking the car tonight, so in case ; any fuel pumps around ottawa, any1?

The Twin 09-12-2012 10:00 AM

I got one if you want.

i'm in Rockland ontario, but work in Ottawa at the Mint right next to the bridge to Gatineau:-)

it's used from my 1990 325ic, I replaced it with a walbro 255 as I'm going turbo

yours if you want it, $50.

Tekals 09-15-2012 10:58 PM

Fixed,

I ended up putting a fuel pump from an e36 320i, the pressure is slightly higher (5psi) and now the motor seems to be working even better.

Thx anyway

The Twin 09-16-2012 01:39 AM

No problem:) glad it worked out 4 u!

ju_le_new 09-16-2012 09:20 PM

Happened to me a month ago, but I got stuck in Rigaud... 2 hrs from home -_- The worst part is that I just changed the pump because the last one was doing a weird squeal AND the other guy in the car had to catch a flight. A good friend of mine finally brought my old pump to me and we changed it in a restaurant parking lot. Ahhh what a day !

The Twin 09-17-2012 09:06 AM

That's my moto with my BMW aswell. Fix it till its broken lol


All times are GMT -4. The time now is 09:59 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014