maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   5 series (http://www.maxbimmer.com/forums/forumdisplay.php?f=61)
-   -   540 catalytic converters failing? (http://www.maxbimmer.com/forums/showthread.php?t=150018)

jmack 04-10-2012 12:37 PM

540 catalytic converters failing?
 
Hey guys,

Wondering if anyone has replaced the cats in their 540 and why... A couple weeks ago the car died on me after a half-hour trip, it would start, then die right away. Seemed to be getting fuel, spark, etc, but would just crap out at idle. I could keep it 'going' with foot on the gas, but that didn't really get me anywhere.

After getting it towed home I can start it and it will run, albeit somewhat weakly with a lower than normal idle, would dip to 400-300 and sometimes less. I haven't been driving it at all as I am fearing getting stuck again.

Listening at the rear exhaust you can hear a pronounced vibration that comes and goes, comes and goes.

Does this sound like a clogged or otherwise toasted cat(s)?

jmack 04-10-2012 12:37 PM

Also no codes.

Quack 04-10-2012 12:55 PM

sounds like it, I had a 98 540, when I bought it the cats were clogged, couldn't do hard acceleration, and would stall out sometimes after driving for 30 mins, also eating lots of fuel, was only getting 300-400km per tank, I had them cut out & replaced with hi-flow cats, car was fine after they were replaced.

jmack 04-10-2012 02:00 PM

Thanks, what cats did you go with? And I am correct that there are 4 that need to be dealt with or did you only replace the rear 2?

Quack 04-10-2012 03:09 PM

well my car is a 98, I think there were only 2 cats, I believe yours has 4, I've replaced them with Brullen hi-flow cats, but the company went belly up many years ago.


All times are GMT -4. The time now is 07:54 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.