maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E30 (1983 - 1991) (http://www.maxbimmer.com/forums/forumdisplay.php?f=58)
-   -   M20 Uses 40L/100km at Idle!! (http://www.maxbimmer.com/forums/showthread.php?t=149714)

Wuzie 03-28-2012 07:12 PM

M20 Uses 40L/100km at Idle!!
 
Hey guys.. my car has been through a bit of mishap. The fuel rail was leaking previously. I swapped the rail from an eta engine, of course the holes didnt line up, we rerouted things around. Kept my blue top injectors and fuel pressure regulator. This fixed the leak, hooray.

Everything was dandy aside from my vacuum leaks. I was getting shitty mpg (around 8mpg honestly) and once I fixed everything, swapped a new elbow intake boot piece, but that was also from an eta engine.. so things didnt line up properly. This fixed the idle for a bit, but then fuel economy was bad again, so I put my stock boot piece back on and taped every leak as well as clamped them shut.

This worked! Started to get down to 8.8L/100km and right now it averages about 20-23mpg while driving. However, at idle, I see the little needle showing consumption shoot all the way to the end. And once I reset the thing on the OBC, it shoots up to 40L/100km !

Whats going on here? Can anyone relate or help me out please?

DIY 03-28-2012 07:30 PM

engine running + wheels not turning = alot of liters per 100km

so maybe it works now?

Wuzie 03-28-2012 07:35 PM

Hmm I see, so what youre saying is that its normal because of the way its presented.. damn I feel stupid hahah

MaxBell 03-28-2012 10:28 PM

Yeh, when you stop the consumption gauge will show infinity L/100kms.

Wuzie 03-28-2012 11:35 PM

Well poop. Here I am thinking the worst thing possible is happening when it all makes sense now lol.. thanks fellas.

/thread

SamE30e 03-30-2012 09:02 PM

That gauge isn't accurate. And it maxes out at a stop.


All times are GMT -4. The time now is 03:15 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.