maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   Off-topic (http://www.maxbimmer.com/forums/forumdisplay.php?f=4)
-   -   and I thought Canada Post was slow... (http://www.maxbimmer.com/forums/showthread.php?t=137834)

MarkD 10-19-2010 02:44 PM

and I thought Canada Post was slow...
 
Well the Postal system in Norway is even worse. Someone mailed a DME to me for a software flash 11 days ago, and it is still not here.

I checked the tracking on it today and here is what it says:


Package has been sent from origin country 18.10.2010 20:27 0024 OSLO

Package has cleared export customs 18.10.2010 08:41 0024 OSLO

Package has cleared customs 15.10.2010 11:20 0024 OSLO

Package has been entered customs clearance by Norway Post 13.10.2010 08:54 0024 OSLO

Package is in export customs clearance 13.10.2010 08:53 0024 OSLO

Package has been sorted and forwarded 11.10.2010 11:56 0024 OSLO

Package has been handed in at terminal and forwarded 08.10.2010 08:26 8200 FAUSKE

Package has been handed in to post office 07.10.2010 11:39 8376 LEKNES


I'm glad I don't live in Norway, it seems they even have EXPORT CUSTOMS clearance! :confused:

MarkD

Quack 10-19-2010 04:05 PM

just wait a little longer, another month or so the DME should be on a plane headed to Canada:D

El Gato Liso 10-19-2010 05:05 PM

perhaps they loved it so much that they had to keep looking at it :D


All times are GMT -4. The time now is 02:15 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2015