maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   General Discussion (http://www.maxbimmer.com/forums/forumdisplay.php?f=2)
-   -   aa rotrex c30 supercharger (http://www.maxbimmer.com/forums/showthread.php?t=135843)

againstallodds 08-10-2010 12:55 AM

aa rotrex c30 supercharger
 
hey guys, its confirmed that my s/c is done!! aa wants 2500 just for a replacement blower, i say no thanks. before i make any decisions on what to do..does anyone know someone or a place that will rebuild this supercharger?? preferably in the toronto/brampton/mississauga area. let me know, your help is greatly appreciated!

Bliss 08-10-2010 01:11 AM

Wow, sorry to hear about your loss. Since AA is leaning all their kits towards the HKS blowers, that might be a good reason why they want so much. Did you try contacting Rotrex direct and ask if they can either direct you to a rotrex supplier, or have them ship you a rebuild kit? I'm actually quite surprised that AA didn't offer you better assistance other than trying to sell you a new sc.

What exactly happened?

propr'one 08-10-2010 01:37 AM

what's wrong with the blower? if its jsut the bearing its like 400$ from http://www.superchargerrebuilds.com/

againstallodds 08-10-2010 09:43 PM

thanks propr'one...id rather not send it to texas? but if anyone has deal with supercharger rebuilds and liked their experience..im interested to hear from you...let me know thanks.

Bliss 08-10-2010 10:00 PM

You still never answered our question as to what happened, and what makes you or AA think you need a new blower? Spun bearing, leaking, broken turbine, broken shaft?

Anyways, if it's a matter of rebuilding then order the rebuild kit from the site that Propr'one linked and if you're somewhat mechanically inclined then tackle the job yourself, if not, then call up one of the techs that sponsor this site, and im sure one of them can help you out.

againstallodds 08-10-2010 10:11 PM

its very loud if that helps.

Bliss 08-10-2010 10:36 PM

Quote:

Originally Posted by againstallodds (Post 1443045)
its very loud if that helps.

If you take the belt off and spin the pulley, does it still make noise? This is a good way to test if its in fact your sc thats faulty, but i'm guessing you already know it is. My guess it's most likely due to overheat. Possibly no oil getting to it, or was low. If you're confident enough to take it apart yourself check for the inside metal components being a black/burnt color. This would indicate that you ran on low oil, and was just burning it off. It could be your bearings that are gone if its noisy, but it really can be anything. I would still do a complete rebuild, and make sure to check your cooling lines afterwards to make sure it's being fed oil. Good luck.

againstallodds 08-11-2010 12:41 AM

i dont think oil getting to it was the case...oil is being fed. thanks alot for our insights though bliss...

ckhmarston 12-13-2010 07:15 PM

I am really bummed out, my C30 just started running very loud, so i checked the oil lines, which seemed to be pumping enough through the return line...then i pulled of the belt and sure enough the S/C was not turning smoothly like i was hoping for. However i did get a better quote from URD for a S/C than $2500. if anyone has knows for sure that this is a clear sign of a bad bering please let me know.... :(

thanks


All times are GMT -4. The time now is 02:58 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014