maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E90/E91/E92/E93 (http://www.maxbimmer.com/forums/forumdisplay.php?f=94)
-   -   A/C and Heat Question. (http://www.maxbimmer.com/forums/showthread.php?t=134774)

Italia311 07-02-2010 02:24 PM

A/C and Heat Question.
 
Hi guys,

Up until yesterday the air conditioner in the car was fine. I went to turn it on and it wasn't working at all/little air coming out of the vents. The only time you could really feel the air coming out was at high speed on the highway. I then tried the heat and same thing, no heat except for when driving fast....

Do you think it could be a fan that's broken? And idea's on what it could be? Cost?

Thanks

Bullet Ride 07-02-2010 03:21 PM

Definitely sounds like the blower fan isnt turning on. I'm guessing there is probably some sort of resistor for the blower motor, located somewhere near the blower motor that could be blown.

You can probably a replacement motor and/or resistor from one of the online parts websites. Motor is probably a couple hundred bucks, resistor is probably 10-15 bucks.

Check out an E9x specific website like e90post other people have probably had similar problems.

Italia311 07-08-2010 04:56 PM

Thanks. I am wondering if it possibly could be a fuse??? I don't know though considering the AC will come on and cold air will come out...just very slowly

Bimmermann 09-06-2010 08:34 PM

Blower motor resistor. Covered under warranty

Datboi 10-05-2010 11:09 AM

Mines was making a screetching sound when i would put on the a/c, it was the fan for me and probably the same for you too from what your saying..it should be covered under warranty..


All times are GMT -4. The time now is 10:43 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.