maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   General Discussion (http://www.maxbimmer.com/forums/forumdisplay.php?f=2)
-   -   Code 104 (http://www.maxbimmer.com/forums/showthread.php?t=134079)

AlpWhitE46 06-09-2010 06:49 PM

Code 104
 
So as some of you read I had the mechanic put in the new vanos and seals + new oil was changed right after.

After second start i got CODE 104 - VANOS exhaust camshaft, end position reached.

This is one of the codes i was getting before, I guess the other one dissapeared..


Does anyone know what this could be now?
The car kinda starts a bit off, and does not idle fully properly...


I HATE VANOS.

mirek 06-09-2010 07:00 PM

Code P0104 is MAF according to my book,

AlpWhitE46 06-09-2010 10:23 PM

What book is that?

Sorry I'm just trying to figure out what the hell else is wrong... What i wrote is what the mechanics computer checked out



I just started it up again and it was studdering the iddle...

uzi577 06-09-2010 11:55 PM

Quote:

Originally Posted by mirek (Post 1427394)
Code P0104 is MAF according to my book,

I think he refers to Bentley manual. I briefly checked the P0101 is MAF(mass air flow). BMW code 8. It is close but I could not locate the P0104.

All the VANOS codes start at P15xx.
good luck

EuroSpec_92 06-09-2010 11:59 PM

ill check it out for you in the morning, i have a better program at teh shop

AlpWhitE46 06-10-2010 01:18 AM

Thanks Euro!

Can't wait to resolve this issue already!

mirek 06-10-2010 01:52 PM

OBDII codes, assuming you used an obd2 scanner,

http://www.obd-codes.com/p0104

MarkD 06-10-2010 04:18 PM

Quote:

Originally Posted by EuroSpec_92 (Post 1427485)
ill check it out for you in the morning, i have a better program at teh shop

What program do you have ? A GT-1 is the best tool to use.

AlpWhitE46 06-10-2010 04:25 PM

I'm not sure what my mechanic used - all i have is a printed receipt that says X431 DIAG report.

MarkD 06-10-2010 07:26 PM

Quote:

Originally Posted by AlpWhitE46 (Post 1427656)
I'm not sure what my mechanic used - all i have is a printed receipt that says X431 DIAG report.

That is the Launch diagnostic tool. http://www.x431.com/ Not as good as a GT-1.

AlpWhitE46 06-10-2010 11:45 PM

So what does this mean?

Could it be the MAF?

I was just parking and as I parked it was studdering, and then turned off..

luckily I was able to turn it on

MarkD 06-11-2010 05:25 AM

Quote:

Originally Posted by AlpWhitE46 (Post 1427801)
So what does this mean?

Could it be the MAF?

What does your mechanic say? If he does not know, you should take it to someone who has a GT-1. RMP has one. I also do, but don't have time to do any scans till next week.

EuroSpec_92 06-11-2010 10:10 AM

The code shows as a bmw-FC code.
There is no P0104.

So if it is the FC code it is Camshaft position timing over advanced. Or system performance bank 1.

Picture attached.

http://i856.photobucket.com/albums/a...n320i/code.jpg

AlpWhitE46 06-11-2010 04:58 PM

last time i turned it on ran perfectly fine...
Here is the second last time i turned it on..
Should the car do this btw when i rev it and release the gas, its like it has a little point where it stops then drops a bit.. then you can hear it studdering..




http://i.imagehost.org/download/0154...-20100611-1418

uzi577 06-12-2010 11:06 AM

Start with a basics

Take the MAF sensor off clean with a carb cleaner.

Or if can get your hands on working MAF sensor plug it in see if it will solve you problem.

BMW is very picky on the reading it gets for the MAF. The range of problems can be cause by it is huge.

Please re-read the codes. It will help you determine further action.


All times are GMT -4. The time now is 09:56 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.