maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E36 (1991 - 1999) (http://www.maxbimmer.com/forums/forumdisplay.php?f=59)
-   -   just finished m50 manifold (http://www.maxbimmer.com/forums/showthread.php?t=127127)

Steve30 11-11-2009 10:13 PM

just finished m50 manifold
 
Hey guys, I just finished my M50 manifold swap today. I Started the car up and everything was perfect except for a slightly louder top end ticking. Is this due the the engine running lean until it adapts to the new air flow? Also, i got a check engine light as soon as i got on the highway. my brother said it could be the MAF due to the new airflow. any help would be appreciated

thanks,
steve

propr'one 11-11-2009 11:07 PM

let everything adjust, see how it is tomorrow

Steve30 11-11-2009 11:13 PM

hopefully thats why the CEL came on. As for the ticking, I think its the injectors. Apparently they are loud as hell without a fuel rail cover on. I'll update this tomorrow.

Quote:

Originally Posted by propr'one (Post 1364988)
let everything adjust, see how it is tomorrow


blk325i 11-11-2009 11:45 PM

the ticking is normal, there should be no CEL, scan it, most likely a vaccum leak

Eurostyle 11-11-2009 11:57 PM

Quote:

Originally Posted by blk325i (Post 1364996)
the ticking is normal, there should be no CEL, scan it, most likely a vaccum leak

+1 on the vacume leak! They can be very sensative to vacume leaks, triggering the CEL. Reset the light and see if it comes back.

Steve30 11-12-2009 12:01 AM

i guess its time to invest in the peak engine tool *shiner*

iverson03tj 11-12-2009 01:36 AM

Was it an easy swap? did u use a kit or found the parts urself?

Steve30 11-12-2009 05:29 PM

i bought the manifold from eurostyle and i used eric's kit from m50manifold.com. the install is very straight forward. the biggest problem i had was the manifold bolt in the back. labelling all the harnesses helps a ton. it took me about 7 hours by myself.

do you think a cracked/ripped intake boot would cause the CEL? I used the original one which did have some tearing. I'm going to BMW tomorrow to buy a new one.

iverson03tj 11-13-2009 05:21 PM

I dont think it Should. Do you know anyone that can tell u the code?

Steve30 11-13-2009 05:37 PM

My friends brother does have a code reader but I haven't had a chance to talk to him yet. I read that any leak post-MFA would throw off the CEL and cause the engine to run lean. I really dont see what else it could be. Every vacuum line is in place.

BmW1819 11-13-2009 09:01 PM

a cracked intake boot after the air flow meter is a vaccum leak and will through a lean mixture code

Steve30 11-13-2009 09:52 PM

I thought so. I ordered the boot from bmw but it wont be in until monday. Will I still need to have the CEL reset with the tool or will it correct itself?

Quote:

Originally Posted by BmW1819 (Post 1365513)
a cracked intake boot after the air flow meter is a vaccum leak and will through a lean mixture code



All times are GMT -4. The time now is 08:00 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014