maXbimmer Forums

maXbimmer Forums (http://www.maxbimmer.com/forums/index.php)
-   E30 (1983 - 1991) (http://www.maxbimmer.com/forums/forumdisplay.php?f=58)
-   -   Why did my e30 not start and then start working fine? (http://www.maxbimmer.com/forums/showthread.php?t=112914)

propr'one 11-10-2008 07:38 PM

Why did my e30 not start and then start working fine?
 
I drove 1500km this weekend (and got pulled over doing 152 km/h, yay), parked the car yesterday, took a nap, went to start it, wouldn't start. Swapped the ECU (known issue on my car) still wouldn't start. Gave up, went to sleep.

woke up today, works great. Swapped the ECU, (just for fun), let it adapt, runs great.

What could it be? it always cranked, just didn't start. I want to fix this as i need this car to be (reasonably) reliable

mirek 11-10-2008 07:38 PM

fuel pump? :)

zackman17 11-10-2008 07:58 PM

Quote:

Originally Posted by propr'one (Post 1224491)
I drove 1500km this weekend (and got pulled over doing 152 km/h, yay), parked the car yesterday, took a nap, went to start it, wouldn't start. Swapped the ECU (known issue on my car) still wouldn't start. Gave up, went to sleep.

woke up today, works great. Swapped the ECU, (just for fun), let it adapt, runs great.

What could it be? it always cranked, just didn't start. I want to fix this as i need this car to be (reasonably) reliable

identicle problem ii took off the hose at the pump and turned over the engine and no gas. so i turned the connector going into the pump, turned over the engine and i was getting gas

Eurostyle 11-10-2008 08:05 PM

It can be a LOT of things, but when it happens again, try to find out if you are missing fuel or spark. That will simplify things a bit....

Some of the things that can work on and off are; fuel pump, sensors (crank, position, etc...) relays (several), fusable links (not fully blown, but bad connection), ECU, wiring...

Also i found my old E30 needed good electrical power to start, eg; wont start, but starts if boosted....

T.Dot_E30 11-10-2008 08:36 PM

When you say wouldn't start, what was it doing?

Was it cranking? As fil said, check for fuel and spark. Then go from there.

everlast 11-10-2008 08:52 PM

I would wager fuel pump relay. Its one of the orange ones under the cover by the intake. If it happens again, swap the two orange ones; the other is the O2 sensor heater. If it starts right away, get a new one!

That's where I'd start anyway.

Has the fuel pump been making any noise?

slimjim 11-10-2008 08:56 PM

^^^or jump it..jump 30 and 89 i think, lol check to make sure

propr'one 11-10-2008 09:03 PM

It was cranking and turning over, just not starting. I'm guessing fuel pump relay also. Can't get it to not start again, it starts every time now:(

everlast 11-10-2008 09:04 PM

Relay's tend to fail at different temperatures. Wait until it gets fully cold again and see if it cacks.

Chris de la Cruz 11-10-2008 09:08 PM

welcome to the world of owning an e30 :)

slimjim 11-10-2008 09:14 PM

^lol ya, by 2-3 years i can safely say ull get to know every bolt in ur car.

Eurostyle 11-10-2008 09:39 PM

Quote:

Originally Posted by Chris de la Cruz (Post 1224554)
welcome to the world of owning an e30 :)

I would say my first ETA was the most reliable car i ever owed...over 4-5 years of abuse, i only did a water pump, and ball joints...The rest was all regular maintenance and mods....Oh and i blew a rad hose, after using it to tow a dolly with a car on it...but that was the original hose from 1985 with 400K on it...lol

sic///M 11-10-2008 09:57 PM

+1 for fuel pump, had the same issue on my cabrio

propr'one 11-10-2008 11:19 PM

the car was on E when it didn't want to start, now its on full and starts every time.

sic///M 11-10-2008 11:22 PM

a car on empty might not want to start for obvious reasons..... but seriously, i heard our pumps dont like a low tank, wouldn't do that very often


All times are GMT -4. The time now is 11:48 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Maxbimmer Copyright 2001 - 2014